3

A variety of machines will happily boot a custom bzImage via PXE in legacy mode using syslinux.

In UEFI mode, one of these machines and a newer UEFI only board get assigned an IP address, TFTP syslinx.efi from the server and then freeze.

Now I'm not quite sure why the freeze.

There are no further TFTP requests as seen when using pxelinux.0.

Wireshark shows that the machine is sending the correct PXE/BOOTP extension for an x64 machine PXEClient:Arch:00007:UNDI:003016.

The syslinux.efi binary is x64 build from the 6.03 sources.

Is syslinux.efi even the correct loader? Any thoughts welcomed.

2

The syslinux.efi is the correct loader; unfortunately 6.03 has several issues affecting both UEFI and PXE.

i.e. http://www.syslinux.org/archives/2016-October/025395.html

this is just an example, there are many more issues, like faulty TFTP transfers, bad next-server detection, etc. The patches for all these issues have been submitted and some of them are already merged you should try 6.04-pre1 binaries.

| improve this answer | |
  • Thank you, I should have thought to check!. The 6.04-pre1 binaries work on a Intel Atom Z8350 board but fail on a (relatively ancient) Dell i5-3317. The UEFI mode TFTP is incredibly slow ... 4 minutes for 14MB? – J Evans Oct 20 '16 at 15:18
  • 6.04-pre1 is still far from production quality, and you are right the TFTP bug is still there. About your ancient Dell she probably needs a firmware update. If you do not mind running your PXE server in Windows you should give Serva try. – Pat Oct 20 '16 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.