2

I'm running Centos 6.8 with 3.18.41-20.el6.x86_64 Xen kernel. Due to this problem (e1000e Detected Hardware Unit Hang) I updated my grub.conf appending arg pcie_aspm=off to the default kernel, but I can't reboot this hypervisor at the moment. I would like to set the variable at runtime if possible.

This is my current status:

# cat /sys/module/pcie_aspm/parameters/policy
[default] performance powersave

Is it possible to echo off > /sys/module/pcie_aspm/parameters/policy in order to achieve the same result? I think it doesn't make sense because off basically disables the function. What's the best option then? Would performance be a good workaround for my case? (see Centos6 ASPM guide)

1

you have to put changes in grub and rebuilt grub to take effect, after reboot it will show you to :-

cat /proc/cmdline BOOT_IMAGE=/vmlinuz-3.10.0-327.el7.x86_64 root=/dev/mapper/rhel-root ro crashkernel=auto rd.lvm.lv=rhel/root rd.lvm.lv=rhel/swap rhgb pcie_aspm=off quiet LANG=en_US.UTF-8

  • You could also edit boot parameters when booting. – Rolf Apr 17 '18 at 21:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.