0

I am begginer in administration of servers. So decided to learn about it a little bit. All actions I perform in the same OS. I setup Microsoft SQL Server 2008 R2 on my virtual mashine(PC name: WIN-EBEI837K420 or IP: 192.168.1.100). SQL Server Management Studio connects remotely. In fields I point out:

Server name: WIN-EBEI837K420,3306

Authentication: SQL Server Authentication

Login/password: xxx/xxx

But, if I try to connect via MySQL Workbench 6.3CE it gives me this error "Lost connection to MySQL server at 'waiting for initial communication packet', system error 10060".

I have tried a wide variety of advice which I could find in internet and after all situation has not changed.

My settings For windows firewall Inbound/outbound rules for TCP port 3306 and UDP port 1434.

SQL Server Configuration Manager -> Server Network Configuration has TCP/IP enabled

Keep Alive 300000 Listen Yes

IP1: Active Yes Enabled No IP Adress 'some mac adress' TCP Dynamic Ports 'empty' TCP Port 'empty'

IP2: Active Yes Enabled No IP Adress 192.168.1.102 TCP Dynamic Ports 'empty' TCP Port 'empty'

IP3: Active Yes Enabled No IP Adress ::1 TCP Dynamic Ports 'empty' TCP Port 'empty'

IP4: Active Yes Enabled No IP Adress 127.0.0.1 TCP Dynamic Ports 'empty' TCP Port 'empty'

IP5: Active Yes Enabled No IP Adress 'some mac adress' TCP Dynamic Ports 'empty' TCP Port 'empty'

IPAll TCP Dynamic Ports 'empty' TCP Port 3306

netstat -an gives

TCP 0.0.0.0:3306 0.0.0.0:0 LISTENING

TCP [::]:3306 [::]:0 LISTENING

What is wrong with my work environment and why I can not establish connection between SQL Server and MySQL Workbench.

0

Microsoft SQL Server and MySQL are two different database products with different protocols between server and client.

You cannot use MySQL Workbench to connect to SQL Server and you cannot use SQL Server Management studio to connect to MySQL.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.