Following error is showed when starting clamd;

freshclam[26882]: [LibClamAV] mpool_malloc():Attempt to allocate 8388608 bytes. Please report to http://bugs.clamav.net

I have lots of RAM memory unused on my linuxOS, but this error keeps showing on the display,I couldn't start clamd daemon because of the error. And now I can't send or receive emails.

Could you tell us the cause of this error and how to solve it?

  • Occurs on Windows servers configured with Immunet. Very serious problem as this line is reported every second in log files until disk fills up
    – Otheus
    Commented Oct 23, 2016 at 12:13
  • Occurs also on Mac OS X Server 10.6.8 (uses built-in clamav). The machine simply hangs and is unusable/unreachable. The only remedy so far for me is to disable it: uncheck "Enable virus filtering" in Server Admin > Mail > Settings > Filters. Since it is built in - I dont see a bright light at the end of the tunnel for this issue...
    – lowtech
    Commented Oct 31, 2016 at 15:44

5 Answers 5


Yeah, it hit me too, here is the bug report: https://bugzilla.clamav.net/show_bug.cgi?id=11647

Upgrade to a new version. I guess you have 0.97 version.


I have the same errors on 8 Servers since yesterday. All Server are Zimbra servers.

I have fixed the problems with updating the Zimbra to new release.

But at one i do not have the option to update.

I think it is a Bug in an old clamd release.


Same problem with me too. I upgraded the clamav package and restarted the clamd and postfix service. It worked for me.

  • How to upgrade? ubuntu? Restarting clamav and postfix makes no change. Commented Oct 26, 2016 at 7:55

In our case (Debian Wheezy) we also had to update the package clamav-freshclam. Maybe the mismatch between clamAV and freshclam had something to do with the error.

sudo apt-get update && sudo apt-get install clamav clamav-daemon clamav-freshclam 

Im my case running freshclam manually solved the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .