-2

Mongo V2.6 is already installed on my server which is probably using glibc-2.12. When I try to install Mongo V3.0.12 it is trying to install glibc-2.14 which it cannot do.

How can I have both glibc libraries live on my RedHat Version 7 64 bit server?

Here is what is currently installed and running:

#-> rpm -qa | grep glibc
glibc-headers-2.12-1.192.el6.x86_64
glibc-common-2.12-1.192.el6.x86_64
glibc-2.12-1.192.el6.x86_64
glibc-devel-2.12-1.192.el6.x86_64

#-> mongo --version
MongoDB shell version: 2.6.7

Here are the errors I am getting when trying to install mongo V3.0.12:

yum install -y mongodb-org-3.0.12 
Loaded plugins: amazon-id, jnj-amazon, rhui-lb, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
...
--> Finished Dependency Resolution
Error: Package: mongodb-org-shell-3.0.12-1.el7.x86_64 (MongoDB)
       Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: mongodb-org-mongos-3.0.12-1.el7.x86_64 (MongoDB)
       Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: mongodb-org-server-3.0.12-1.el7.x86_64 (MongoDB)
       Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: mongodb-org-tools-3.0.12-1.el7.x86_64 (MongoDB)
       Requires: libc.so.6(GLIBC_2.14)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

So I got the RPM I need but it won't install:

#-> rpm -i glibc-2.14.1-14.12.5.x86_64.rpm
warning: glibc-2.14.1-14.12.5.x86_64.rpm: Header V3 RSA/SHA256 Signature,
    key ID 3dbdc284: NOKEY
    file /usr/share/man/man1/localedef.1.gz from install of 
        glibc-2.14.1-14.12.5.x86_64 conflicts with file from package 
        man-pages-3.22-20.el6.noarch
    file /etc/gai.conf from install of glibc-2.14.1-14.12.5.x86_64 
        conflicts with file from package glibc-2.12-1.192.el6.x86_64
    file /etc/ld.so.conf from install of glibc-2.14.1-14.12.5.x86_64
        conflicts with file from package glibc-2.12-1.192.el6.x86_64
    file /etc/nsswitch.conf from install of glibc-2.14.1-14.12.5.x86_64 
        conflicts with file from package glibc-2.12-1.192.el6.x86_64
  • 1
    This isn't a RHEL 7 server. – Michael Hampton Oct 24 '16 at 21:22
  • Yes, you are correct, but I don't think the RHEL release matters. cat /etc/redhat-release Red Hat Enterprise Linux Server release 6.6 (Santiago) – user1356863 Oct 25 '16 at 13:19
  • Of course it matters. And trying to install packages that aren't even for RHEL is a great way to break your system, too. Which is why you weren't allowed to do it. – Michael Hampton Oct 25 '16 at 13:35
  • So would my best bet be to use a RHEL7 server and install both mongo V3.0.12 and mongo V2.6? – user1356863 Oct 26 '16 at 13:57
0

After doing much googling and reading the glibc library seems to be too difficult to replace. My server that I was originally going to use was running RHEL6.6 Santiago which has glibcV12.

Instead I spun up a new RHEL7.2 server which has glibcV17. (In my readings I learned that glibc is backwards compatible meaning yes ... I can install both Mongo DBV2.6.7 and MongoDB V3.0!!!)

First I followed the directions to install MongoDB V2.6.7 from any number of websites. This mongod executable will be the default and live in the /usr/bin directory.

Second I followed the directions listed here to install MongoDB V3.0: Installing multiple mongoDB versions on the same server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.