0

How can I throttle IIS in terms of mails per second? and if that's not the case, since I can't find any parameters for such a feature.

Will SMTP IIS automatically queue and resend mail if the initial attempt to send results in a "454 Throttling failure: Maximum sending rate exceeded" response from the Amazon SES SMTP server?

Update: We performed several test, 2 SMTP servers sending 5K mails each, 300 byte small (small size to boost the send rate) to see how the IIS SMTP server reacts. Both logs indicate 454 throttling errors from Aws Ses (1500 errs in total), however no mails were lost, all 10K mails were received.

This leads us to the maybe preliminary conclusion that IIS SMTP handles the 454 throttling response very well.

  • Are you sure a "454 throttling error" still delivers the email? AWS documentation says otherwise: If you attempt to send an email after reaching your maximum sending rate, Amazon SES drops the message and doesn't attempt to redeliver it – Doug S Oct 9 '18 at 0:29
  • Hi Doug, Aws sends the 454, and does not receive the emaIl from IIS. IIS decides to resend. "From the outside" it seems that SES does not send, but actually it doesn't even receives. On the other hand IIS, receives the 454, and decides to try again later. – Paul Oct 9 '18 at 5:29
0

https://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/657bb5ee-e48b-4a6d-9e2f-ac49b959a1bc.mspx?mfr=true is how to do it in IIS6. As you didn't state which version of IIS you are using. This rate limits the number of messages per connection. I think there are other settings in the same location that should help you out.

| improve this answer | |
  • Nope #connections, network latency, message size, there is no formula to fit msg/sec with those settings and variables – Paul Oct 26 '16 at 4:40
  • Hi Paul, just found this. blogs.technet.microsoft.com/bspieth/2013/02/18/… – Tim Haintz Oct 26 '16 at 20:27
  • $virtualSMTPServer = Get-WmiObject IISSmtpServerSetting - namespace “ROOT\MicrosoftIISv2” | Where-Object { $_.name -like “SmtpSVC/1” # Set maximum message size (in bytes) $virtualSMTPServer.MaxMessageSize = ($incomingEMailMaxMessageSize * 1024) # Disable session size limit $virtualSMTPServer.MaxSessionSize = 0 # Set maximum number of recipients $virtualSMTPServer.MaxRecipients = 0 $virtualSMTPServer.MaxBatchedMessages = 0 – Tim Haintz Oct 26 '16 at 20:28
  • What version of IIS are you using? – Tim Haintz Oct 26 '16 at 20:35
  • iis smtp 6 (that is the current version) – Paul Oct 27 '16 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.