2

I searched a lot and everyone says add these in config file and it will work:

location /my_directory {
    autoindex on;
}

I opened /etc/nginx/nginx.conf file and added it under http but service did not start. Added it under http -> server and received 403 forbidden error.

I have no idea about nginx. Can someone tell me easily about what should I do?

Thanks

1 Answer 1

4

You need to add the:

location /my_directory {
    autoindex on;
}

In the file in your /etc/nginx/sites-enabled directory that corresponds to the virtual host your site is using. There is already a server block in the file, so you simply place the location block inside the server block.

1
  • I added location settings at /etc/nginx/sites-available/default file and after restart (service nginx restart) it worked. Thank you. Oct 26, 2016 at 14:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .