0

Intro:
I have 1 server with an onboard NIC and 1 usb NIC, the onboard NIC is for network 1 (my home network) and the usb NIC is for network 2 (my virtual network) so they are separated and do not interfere with each other.

Virtual program:
I use Hyper-V for all of my virtual machines and I have my usb NIC set as a virtual network and selected in Hyper-V which NIC it needed to use so that my networks are separated.

What i have done:
I installed Windows Server 2012 R2 on my virtual machine, I checked my own computer and looked which ip my computer got (network 1) and I checked what IP my virtual server got (network 2) my virtual server had a different IP, so I assigned a static IP 192.168.2.2 and I installed my Active Directory, DNS and DHCP. Then I got this message:

A delegation for this DNS server cannot be created because the authoritative parent zone cannot be found or it does not run Windows DNS server

I searched but it didn't made sense because the AD and the DNS are on the same server and on the same network but I have seen that most people say do not bother it because it is on the same server. For some reason my DHCP won't give IP addresses, god knows why, and I can not do a network boot because of that. It really is annoying me

Problem:
I can't get WDS working and I don't have a single clue anymore where to look or how to find out. It is my first time with WDS and I have searched multiple sites and videos for help or how to do it but without luck.

Could it be that it has to do with my other network?!

Thank you in advance!

  • What does the PXE client say when it tries to network boot? Thanks! – Elliot Labs Oct 26 '16 at 21:27
  • It is best to keep the services as separated as possible because if one is compromised then the rest are on the same machine, easy pickings. If they are on separate machines then if one is compromised they would have to compromise each other one individually. It is the same for system reliability, if the one machine that runs everything fails then everything fails. If you distribute the workload then there would be no single point of failure. If it is just a test network then it should be safe to run everything off of the one server. – Elliot Labs Oct 26 '16 at 21:30
  • Also did you install all of them at the same time, or some specific order? I generally start from a fresh install then install ADDS (as a DC) then run the setup wizard for ADDS, it will install and config DNS as needed. after that has finished then I install WDS and DHCP. WDS will link up with ADDS. Configure the DHCP server to distribute IPs and set WDS to use the onboard DHCP server (properties dialog of WDS system). – Elliot Labs Oct 26 '16 at 21:33
  • If you want just WDS then you can run it without ADDS and DNS. It runs purely from DHCP and the WDS module. – Elliot Labs Oct 26 '16 at 21:41
  • Hello elliot, yes i did a fresh install and first began with ADDS and when i did that i got that error message why i don't know because i'm on a seperate network. this is still a test enviroment so i like to keep it on 1 system. when i try to PXE boot it says: no dhcp or proxydhcp offers were received. this i don't get because they are on the same network i have set the DHCP pool and set the dhcp pool is set from 192.168.2.3 to 192.168.2.10. i can see on the server and on the client that the nics are glowing and blinking 1 green and 1 orange – Gandalf Oct 27 '16 at 6:47
0

Have you checked your Hyper-v settings? it could be you use the normal network adapter. You should be using the Legacy Network Adapter.

Here is the link for the answer: Hyper-V network adapter differences

read the last 2 paragraph's that will explain a lot.

these are the steps to do it: go to your VM > Settings > Add Hardware then select Legacy Network Adapter then click on Add, this will add the legacy network adapter now you can assign the right NIC to the network adapter i did remove the other network adapter so i won't make any mistake by choosing the wrong network adapter.

Hope this will help you and anyone else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.