I am attempting to patch the Dirty Cow vulnerability by running the following command on my Ubuntu 12.04 server:
sudo apt-get update && sudo apt-get dist-upgrade
This results in the follow error(s):
The following packages have unmet dependencies: lsb-base : Breaks: upstart (< 1.12.1-0ubuntu8) Breaks: upstart:i386 (< 1.12.1-0ubuntu8) plymouth : Depends: initramfs-tools but it is not going to be installed Recommends: plymouth-theme-ubuntu-text but it is not going to be installed or plymouth-theme udev : Depends: initramfs-tools (>= 0.92bubuntu63) but it is not going to be installed Depends: util-linux (> 2.15~rc2) E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
What do I need to do in order to fix these errors?