0

Please excuse any formatting or grammatical errors.

I am currently using automysqlbackup to take local backups of my mySQL database. I recently started to having problems that is connected to that automysqlbackup (or in fact mysqldump) does lock the tables before dumping.

I have not access to any mySQL user or the root user, only the /etc/mysql/debian.cnf.

I would need to add the parameter "--lock-tables=false" so automysqlbackup does'nt lock the tables. I am aware of the risks that follows.

  • Read also stackoverflow.com/questions/104612/… – lg. Oct 27 '16 at 14:29
  • @lg. It seems that you did not read the question. This question is about automysqlbackup that uses mysqldump - not mysqldump itself – Orphans Oct 27 '16 at 14:34
  • I read your question. I only suggested you to read that post because the option to include changes for myisam and innodb engine. – lg. Oct 27 '16 at 15:00
1

I've added this option on /etc/default/automysqlbackup

OPTIONS

OPT="$OPT --lock-tables=false"

  • 1
    Yes, that is the correct solution! – Orphans Dec 20 '18 at 11:34
0

I solved this myself.

Line 431 in /usr/sbin/automysqlbackup contain the "command", editing that line solved my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.