1

I have a Windows Server 2016 machine installed with WSUS. I have the firewall port 8530 and 8531 allowed through. I have 10 updates approved and ready for download. I have a GPO with 3 computers in it with the Intranet location for WSUS set to HOSTNAME:8530 and Stats server set to http://HOSTNAME:8530

I am trying to get the laptops on Windows 10 x64 to connect to the server and pull the updates. When I go to connect to the WSUS server Windows Updates states:

We couldn't connect to the update service. We'll Try again later, or you can check now.

This is my first WSUS install so I need a little help. When I run the ClientDiag.exe on the client I get the following.

Checking Machine State
Checking for admin rights to run tool -- PASS
Automatic Updates Service is running -- PASS
Background Intelligent Transfer Service is running -- PASS

GetFileVersion(szEngineDir,&susVersion) failed by hr=0x80070002

The System cannot find the file specified

Press Enter to Complete

If I go the browser and go to http://HOSTNAME:8530/Setup/iuinet.cab it successfully downloads the cab file. So it can reach the location.

I cannot figure out how to get ELTs and the WindowsUpdate log to show me any USEFUL information since they moved it to that stupid ELT through PowerShell configuration.

What am I missing or am unable to see why my client cannot connect to WSUS?

  • Try downloading and manually installing the September 2016 cumulative update, KB3193494, or later. The release version of Windows 10 build 1607 seemed to have some serious bugs in the update client and I think Server 2016 has the same problem. – Harry Johnston Nov 1 '16 at 2:23
  • ... although on second glance it sounds as if you've got the intranet location set differently to the stats server? These must be identical strings, i.e., http://hostname:8530 – Harry Johnston Nov 1 '16 at 2:25
  • @HarryJohnston currently the settings in GPO are set to HOSTNAME:8530 and HOSTNAME:8530 – JukEboX Nov 2 '16 at 19:31
  • I'm not certain, but I think you need the http:// part. – Harry Johnston Nov 2 '16 at 21:07
  • 1
    So only one of the settings has the prefix? They have to be exactly the same, prefix and all. (Or at least this used to be a firm requirement, and I haven't heard that it has changed.) – Harry Johnston Nov 3 '16 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.