0

I'm documenting this here as I spent ~3 days on and off trying to get my head around these specific problems and there was surprisingly little on the web.


I have a HP ProLiant Gen8 G1610T which I want to use as a media server so I bought 2 x 4 TB WD RED HDDs to stripe for ~8 TB of storage capacity.


Attempt #1

I:

  1. Used the Smart Storage Administrator to create a 8 TB RAID 0 / striped volume.
  2. Booted to a Windows installer USB flash drive (Rufus + SW_DVD9_Win_Svr_STD_Core_and_DataCtr_Core_2016_64Bit_English_-2_MLF_X21-22843.ISO).
  3. Loaded the driver HP Dynamic Smart Array B120i/B320i SATA RAID Controller (http://h20564.www2.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5387585&swItemId=MTX_07615039b81a44fda3bf51e9ac&swEnvOid=4231).
  4. Selected the ~7.2 TiB volume.
  5. Installed Windows Server 2016 Standard.

This worked fine but there was only a 2 TB partition which couldn't be extended as it was initialized as MBR.


Attempt #2

As advised by http://www.thewindowsclub.com/convert-mbr-to-gpt-disk, I tried to convert the partition from MBR to GPT but it didn't work.


Attempt #3

I looked for how to change the "BIOS mode" from legacy to UEFI to allow booting to a GPT-initialized drive but, according to many sources (https://community.hpe.com/t5/ProLiant-Servers-Netservers/Microserver-Gen8-UEFI/td-p/6499756, http://homeservershow.com/forums/index.php?/topic/9643-how-to-enable-uefi-in-microserver-gen8/, https://community.hpe.com/t5/ProLiant-Servers-ML-DL-SL/ML350p-Gen-8-UEFI-bios/td-p/6293177), the only HP ProLiant Gen8 to support UEFI is the DL580.


Attempt #4

I cleared the RAID config and did the same as attempt #1 except created seperate 250 GB and 7.75 TB RAID 0 / striped volumes and selected the former to install but this time I encountered the following errors:

Windows can't be installed on this drive (Show details)

 

Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk. Ensure that the disk's controller is enabled in the computer's BIOS menu.

 

We couldn't create a new partition or locate an existing one. For more information, see the Setup log files.

 

enter image description here enter image description here


Attempt #5

I used Command Prompt / diskpart to clean, partition, format, active, assign etc both RAID volumes but still encountered the same errors.


Attempt #6

I cleared the RAID config and did the same as attempt #1 except created only a 250 GB striped volume but still encountered the same errors.


Attempt #7

I cleared the RAID config and did the same as attempt #1 but still encountered the same errors.

0

During my extensive DuckDuckGo- and Google-ing, I read something that recommended removing all USB drives but I dismissed that thinking "What? I'm installing off of a USB flash drive? How would that work?"

Apparently, the problem was indeed that a USB flash drive was connected - my other USB flash drive (the one containing the RAID controller driver).

Connecting my other USB flash drive post-boot worked absolutely fine.

This is what I unknowingly did in attempt #1 - I booted into the Windows installer, saw that it didn't have a driver for the RAID controller, downloaded it on my PC to my other USB flash drive, and then connected it.

Bizarre but there you have it.

Also, I don't know if it's relevant but the problematic USB flash drive is USB 3.0 and has FalconFour installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.