1

I'm trying to setup my project with docker-compose up -d on google container engine. This resulted in an error message

ERROR: The Docker Engine version is less than the minimum required by Compose. Your current project requires a Docker Engine of version 1.10.0 or greater.

I proceeded to upgrade docker-engine with sudo apt-get upgrade docker-engine, which lead to a conflict between client API version and server API version as witnessed by docker version :

Error response from daemon: client is newer than server (client API version: 1.24, server API version: 1.21)

This I managed to deal with by DOCKER_API_VERSION=1.21 docker info. The result is

Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 0
Server Version: 1.9.1
Storage Driver: aufs
Root Dir: /var/lib/docker/aufs
Backing Filesystem: extfs
Dirs: 0
Dirperm1 Supported: true
Logging Driver: json-file
Plugins:
Volume: 
Network: 
Swarm: 
NodeID: 
Is Manager: false
Node Address: 
Security Options:
Kernel Version: 3.16.0-4-amd64
Operating System: Debian GNU/Linux 8 (jessie) (containerized)
CPUs: 1
Total Memory: 1.664 GiB
Name: cs-6896-devshell-vm-eb4ae861-f469-41bb-a126-c0f68ecdb2b3-10e
ID: X75G:3CR6:QA5D:PFO3:Y2ZM:FEI3:LDLW:TM7B:2JGT:HLXF:67Q5:K76D
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
WARNING: No swap limit support
WARNING: No kernel memory limit support
WARNING: No cpu cfs quota support
WARNING: No cpu cfs period support
WARNING: No cpu shares support
WARNING: No cpuset support
WARNING: bridge-nf-call-iptables is disabled
WARNING: bridge-nf-call-ip6tables is disabled
Insecure Registries:
127.0.0.0/8

However, I still get the same error of docker engine being too old. sudo apt-get upgrade docker-engine does not help.

How can I update docker-engine, or get to run docker-compose otherwise?

  • Any news on this? – user387517 Nov 25 '16 at 11:24
1

You might not be able to use docker-compose on Kubernetes but this discussion mentions some alternatives.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.