1

I'm a little stuck with applying an Exchange 2010 sp3 rollup package. I have all up to pack 11 installed but 12 fails to install with a 1603 error rolling back as soon as it stops the services. The log has a variety of errors so will post snippets of each and hopefully someone will be able to help.

These errors are in reverse order with last one in the log first.

MSI (c) (00:6C) [16:35:05:521]: Note: 1: 2262 2: Error 3: -2147287038 MSI (c) (00:6C) [16:35:05:521]: Transforming table Error.

Followed by

Property(C): msgINTERIMUPDATEDETECTED = Unable to install because a previous Interim Update for Exchange Server 2010 has been installed. Please use Add/Remove Programs to uninstall the Interim Update before running this setup again.

There are no interim updates present in the ARP list

The next is a little confusing as there only appears to be one architecture version (x64) of this rollup available as far as I can see. I've been trying to find out how to check which version of Exchange is installed but not managed to find this yet. I'm pretty sure it's 64-bit. The rollup package is x64.

Property(C): msgRequiresProc = The version of this file is not compatible with the version of Exchange Server 2010 that you're running. Check your computer to see whether you need an x64 (64-bit) or x86 (32-bit) version of this file.

The next one seems contradictory as am logged on as a domain administrator which in turn has Exchange Server Administrator permissions. I've also got another domain administrator to try installing this with no luck.

Property(C): msgErrorExchangeAdmin = The user who's currently logged on doesn't have sufficient permissions to install this package. You need at least Exchange Server Administrator permissions on the current computer to complete this task.

Then

MSI (c) (00:30) [16:34:52:567]: Note: 1: 2262 2: Error 3: -2147287038 DEBUG: Error 2826: Control BottomLine on dialog FatalError extends beyond the boundaries of the dialog to the right by 5 pixels The installer encountered an unexpected error while installing this package. This may indicate a problem with this package. The error code is 2826. The arguments are: FatalError, BottomLine, to the right

I dare say these are all errors relating to different components being installed in the rollup so hard for me to put my finger on it.

I've been running the installer from an administrator prompt and UAC is disabled as per many suggestions out there. Am I missing anything obvious?

3
  • Ok, so having spent more time on this with the help of the following article (technet.microsoft.com/en-us/library/ff772434(v=exchg.80).aspx), it appears that all of the above errors are false positives and generated only because verbose logging is enabled.
    – jshizzle
    Commented Nov 2, 2016 at 17:07
  • Following on from my last comment, what I have found is that the first "Return value 3" event is what'll provide me with the real cause. In this instance this points to the inability to run a PS script as per case 1 in the above troubleshooting article but my policy is set to unrestricted on the server so should be able to run so again I'm a little confused.
    – jshizzle
    Commented Nov 2, 2016 at 17:23
  • I have now managed to progress this by following the last post in this thread translate.google.co.uk/translate?hl=en&sl=de&u=http://… but now fails in the same way at the end of the installation when trying to start the services instead.
    – jshizzle
    Commented Nov 10, 2016 at 14:34

2 Answers 2

1

Well I've finally got the bottom of this much to my relief...and exhaustion.

Turns out it was down to an issue with some code in the PowerShell script "C:\Program Files\Microsoft\Exchange Server\V14\Bin\ManageScheduledTask.ps1" which the RU ran during the install process. Running this manually resulted in the error:

At C:\Program Files\Microsoft\Exchange Server\V14\Scripts\ManageScheduledTask.ps1:462 char:5
+ return $success
+ ~~~~~~~~~~~~~~~
Flow of control cannot leave a Finally block.
+ CategoryInfo : ParserError: (:) [], ParentContainsErrorRecordException
+ FullyQualifiedErrorId : ControlLeavingFinally

Solution was provided in the last post here: http://www.expta.com/2012/08/exchange-2010-sp2-roll-up-4-does-not.html

My problem was that I installed PowerShell v3 before Update Rollup 4-v2, so "control cannot leave a finally block" was an issue. Rather than substituting an entirely blank script or commenting out the return statement in C:\Program Files\Microsoft\Exchange\V14\Scripts\ManageSchedul edTask.ps1, I changed "return $success" to the logically equivalent "Write-Output $success" in line 462.

I'm obviously installing a later RU but was still getting the same "control cannot leave a finally block" error during manual run.

0

Number one issue with rollup installations is the download was bad.

Therefore the first thing I always do when I get an error is download the update file again. I would suggest that you start there.

You don't have to install the rollups in order, and 12 is old (December 2015) so I would skip straight to 15. https://www.microsoft.com/en-us/download/details.aspx?id=53678

1
  • Hi Sembee, I forgot to add that I'd already tried applying rollup 15 and so tried this version (12) to see if it was the file, like you mention. It wasn't. The same outcome happens regardless of update applying.
    – jshizzle
    Commented Nov 1, 2016 at 15:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .