0

I am having a strange issue with a Windows Web Server 2008 R2 SP1. It's running on metal, no VM stuff here. It's a Lenovo ThinkServer server with 16 GB of RAM, Xeon, 4x Intel SSDs in RAID 5 and a 2 TB rust spinner. It worked fine since February until about a month ago when the problem started to surface, we believe after a Windows update.

What happens: the machine slowly becomes unresponsive until nothing can be done and has to be power cycled. This happens every 1 to 3 days, it never worked for more than 3 days without freezing. I checked the Windows logs, nothing out of ordinary there, except the "The system has rebooted without cleanly shutting down first" stuff.

I will describe what happened today. I see the machine frozen, so I power cycle it and install ScreenConnect. The rest of the actions are done remotely. I installed Prime 95 to see if the issue is related to the hardware. I have up Windows Task Manager. At some point, about 30 minutes after starting Prime 95, I see the CPU at 0%. I try to get into Prime 95 menus, but Prime 95 seems frozen. Task Manager was working though. Then I switch the Firefox, which seemed to be working initially, but it stopped responding within 10 - 15 seconds.

Task Manager was still fine, I was able to interact with it. Then I pressed the Start button with the mouse, nothing happens. Alt-Tab does not work as well. Task Manager is still fine at this point, but within another 10-15 seconds it does not respond as well. At this point Task Manager freezes as well, but ScreenConnect does not report a lost connection. I can move the mouse, and that's it. The local keyboard is not responsive, but the mouse of course is. The machine cannot be used, and has to be power cycled.

I had my share of blue screens and computer freezes, but never something this odd. At the moment we have provisioned another server, but I would like to know if it's a hardware or software (most likely) issue. I would like to use the server for other tasks.

Machine is frozen, but the remote connection is still up:

Machine is frozen, but the remote connection is still up

  • Anything in the event log worthy of a mention? Storage OK? – john Nov 2 '16 at 21:32
  • Nothing in the log. Everything normal, then the reboot. No errors. The discs were tested with the Intel SSD diagnostic tool and they are all fine. If there's a problem with the RAID controller, I can't catch it. The system is configured to save a full memory dump, but no dump is saved. It may be something related to storage. I am ruling out the CPU and memory, problems with them are usually resulting in BSODs or sudden reboots. – R Azvan Nov 2 '16 at 22:20
  • 1. Load Resource Monitor when the server is exhibiting this behavior and take a look at CPU, Disk, Memory, Network, etc. 2. This smells like a possible HDD problem. Do you have any hardware monitoring in place? – joeqwerty Nov 2 '16 at 22:43
  • No hardware monitoring. I left it running last night, with Resource Monitor up, showing Disk tab . This morning it's not responding, but the Resource Monitor seems to be running (the scrolling green graphs are moving) and no application is shown. Looks like a storage problem. Like the storage controller goes to sleep and never comes back, but there are no sleep or power settings for it. I will try to upgrade the RAID drivers. – R Azvan Nov 3 '16 at 14:40
  • how about issuing a powercfg -l to see which power saving settings are set on the system. You can then delete them with powercfg -delete <GUID> and disable hibernation with powercfg -h OFF – John aka hot2use Nov 4 '16 at 8:21
0

Thanks john and joeqwerty for pointing out the problem. It was the RAID controller driver. The server has been up for 4 days now with the newest driver I downloaded from Lenovo's support site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.