I am trying to backup all my mailboxes to another computer. I am using the following command:

dsync backup -u '\*@\*' remote:vmail@backup.example.net

The problem is that I have lots of mail accounts that only do a redirect using sieve, for example contact@example.net to support@example.net. In case of these mailboxes the .dovecot.sieve file is not backed up. As soon as I allow one mail to be saved (by temporarily changing the discard; to keep; in the sieve script) .dovecot.sieve is also backed up at the next dsync run.

This is Dovecot 2.2.9 on Ubuntu 14.04.5 LTS but the backup computer runs Ubuntu 16.01.1 LTS with Dovecot 2.2.22.

  • A bug report on the Dovecot mailing list seems like the better place for this question -- Dovecot missing information during replication definitely feels like a bug. – Jens Erat Nov 3 '16 at 21:01
  • The reason I went for the question not for the bug report is because unfortunately upgrading dovecot is not an option on the source server. So I'm hoping someone already figured out a workaround. Just in case anyone is wondering, for now I created script that creates a tar from all the .dovecot.sieve files and transfers it to the backup computer using sftp using the remote vmail account (lftp is good for this). – soger Nov 8 '16 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.