I have been running SQL SERVER Express 2008 on Server 2012 R2 for some time. I recently began researching the migration process to move to SQL SERVER EPXRESS 2016. Because the original DB was migrated from Express 2005 the compatibility level was 90 and I need to stop at 110 in order to migrate to 130. 110 provided new object types and query advances such as IIF clause. The Data Migration Tool identified these necessary updates.

In the process upgrading the SQL, I am now getting the following error :

TITLE: SQL Server Setup failure.

SQL Server Setup has encountered the following error:

Version string portion was too short or too long..

For help, click: http://go.microsoft.com/fwlinkLinkID=20476&ProdName=Microsoft%20SQL%20Server&EvtSrc=setup.rll&EvtID=50000&EvtType=0x6343E456%25400x294A9FD9

the link is useless as MS reissued it.

The error appears after selecting the "New SQL Server Stand-alone installation or add features to an existing installation" at the top of the SQL SERVER Installation Center window. Just as test I tried SQL 2016 Express as well. Same error.

I found some posts about changing the registry, delete older version of the .Net referenced in the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\User Agent\Post Platform

this did not work.

I have tried numerous .Net Framework test tools to validate each version. No errors found, but then these tools appear to have not yet been updated for Server 2012 R2.

Currently my server is sunk, no working DB.

I have confirmed that the .Net Framework 3.5 and 4.5 Features are in fact installed, via Server Manager.

Also I have tried the REPAIR option and virtually every other available feature in the SQL Server Installation Center. It produces the same error.

Any insightful help would be a pleasure to review.

UPDATE: All SQL installations were removed through Control Panel and where that was unsuccessful via the method described from Aaron Burtrand was used to clean up the registry...his blog The same error continues.

  • Do you got a OS with a language pack ? I got some weird issue like that with a french OS and an SQL install, that was in english. It badly supported the localization.
    – yagmoth555
    Nov 11 '16 at 15:10
  • Checking but I do not believe there are any unusual language packs installed.
    – htm11h
    Nov 11 '16 at 16:45
  • Just a stab in the dark, but SQL Server 2016 is 64 bit only - Check out this blog. Is your server or your old instances of SQL server using 32 bit?
    – tyelford
    Nov 14 '16 at 5:58
  • Everything is 64 bit. I did find the constraint on WOW64 in my research as well, thanks for the link.
    – htm11h
    Nov 14 '16 at 16:59

I would consider posting this as a comment but due to a lack of rep, i can't.

Try moving the SQL database files (.mdf and .log) to a new Windows VM, and upgrade the database files there. Then uninstall anything SQL related on your server, install SQL 2016 Express and reattach the upgraded database files to it.

  • Yep, tried that too.
    – htm11h
    Nov 11 '16 at 14:54
  • This is really not a viable solution worthy of the bounty. It seems obvious that new VM would properly configure correctly!
    – htm11h
    Nov 14 '16 at 17:09
  • As further note on this answer, it is not the database files that are at issue. The problem is installing SQL Express 2016.
    – htm11h
    Nov 14 '16 at 19:31

In the interest of resolving this problem, and with no feedback directly from Microsoft on their site, (likely since the version is no longer supported) I have whipped and reloaded the OS from scratch loaded SQL 2016 Express and have everything running as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.