I'm having a bit of trouble getting e-mail aliases to sync with Office 365 when using Azure AD Connect. I have managed to get all the on-premise AD accounts to sync with Office 365 but cannot for the life of me get the e-mail aliases added. I have read countless forums that say edit the "proxyaddresses" field for each AD user account with "SMTP:email@domain.com" for the primary address and "smtp:email@domain.com" which I can do, however when I run the resync aliases are simply not synced. I can confirm the aliases I'm trying to add are verified domains within Office 365. Has anybody experienced this before? I've added a UPN for one of the domain names as we were using domain.local previously, I have set each user to use the UPN using the IdFix Tool which again has all worked fine but still aliases don't seem to be syncing!?

Any assistance would be greatly appreciated.


You have to include those extra domains in your configuration for Azure AD Connect. Re-run the wizard and there should be a section in there to add more domains.

| improve this answer | |
  • Hi, thanks for your response. I can confirm I have added the domains as part of the initial setup wizard. – Jonathan Baird Nov 7 '16 at 11:15

IF you have already verified the domains in the tenant, check in Exchange Online to be sure they are listed as accepted domains. If they are not - you may need to contact MS support as they may need to run a back-end sync job for you.

If both verified and accepted domains are correct and your still not seeing objects, I would recommend you pick a few test objects, and first ask Microsoft to still do the back end sync and give them the objects. If that works you can let them know you need it done for all objects in the tenant. If that doesn't work then you may need to "Jiggle" the sync operation entirely.

Move those initially selected objects to an OU that is NOT syncing. Run a sync, and this should result in object being removed from the Azure AD database. Also be aware this will put your user object in Office 365 in a deleted state temporarily. Validate you can no longer find the object by opening the Synchronization Service application and clicking the Metaverse. Search for one of the objects we removed, it should return 0 results. If the objects are still there run another sync.

Once the object is no longer in the database, and you have also confirmed the account is not an active account in Tenant, you can move the users back to the original OU and then sync them again. In Office 365 check the user object and validate all data has synced. If this works, you can run thru your existing objects and complete this process and get things working as expected again.

If you run through this and the object is never removed from the Metaverse database, you need to install a new instance of Azure AD Sync.

I've had to go thru this process for numerous attributes that for whatever reason fall "Out of sync". While it's rare - it does on occasion affect an entire object type like "users" or "groups".

| improve this answer | |
  • Hi, thanks for your response. I can confirm that the 2 domain names in question do appear in accepted domains and are showing as "Authoritative". I have moved the user out of the OU, ran a sync and the moved the used to Deleted Users in Office 365, i then put the user back into the OU and created an additional test user and both users sync'd fine. The user sync seems fine it just seems it is not picking up the "proxyAddresses" attribute from my AD. We have added a UPN for the domain name which is picked up by the wizard so I am at a loss as to why the aliases are not synced! :( – Jonathan Baird Nov 7 '16 at 11:17
  • If you search in the Azure AD Sync are the proxy addresses present? If "no" I would suggest installing a new instance of the Azure AD sync tool as that means it's not importing the values at all. If they are there, then the problem could simply be with the Azure AD connector or something more on the Microsoft side (either way you will probably need to contact Microsoft to go further). – Jesus Shelby Nov 7 '16 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.