7

We have recently started to install Server 2016, and seem to be hitting the 'we're going to reboot this server when we feel like it' brick wall. With preview five this was easily rectified using the group policy to configure automatic updates and setting to '3 Auto download and notify for install' - then, after installing the updates it would patiently wait for a manual reboot, with a big red notice 'Some settings are managed by your organisation.'

This doesn't have any effect with the release version and we get the ominous 'Your device is scheduled to restart outside of active hours' message - active hours are all hours except the Saturday after patch Tuesday when we have notified our customers to expect scheduled maintenance...

Is there a new trick I'm missing?

Thanks

  • 1
    There is a uservoice entry for increasing the amount of "active hours" that can be specified for Windows Server. – Heinzi Jun 20 '17 at 10:16
2

Seems like the only answer is to disable ‘Reboot’ in Task Scheduler UpdateOrchestrator and rename the Reboot file to prevent Windows re-enabling the schedule again… It would be bad enough having a desktop rebooting of it’s own accord – but a server??

2

SCONFIG doesn’t prevent reboots outside of active hours. Go into task scheduler, scroll to Update Orchestrator look for the “reboots” task open actions and replace the entry with something else. Removing the “system” permission or setting the perm to “deny” on the “reboots” task perms doesn’t work as the OS resets the perms.

-1

you can use sconfig to adjust the windows update settings. There you can select automatic download only or manual.

  • It's already set for manual download, the problem is it wanting to reboot after installing (we generally run the installs on the Friday after patch Tuesday and reboot on Saturday morning).. Seems we can no longer install some downloads and not others - MS missed Feb, we installed March and it came back with another 'you may have to restart your computer' patch the day after - now we are painted into a corner. – gchq Mar 22 '17 at 0:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.