1

I have a Dell md3000i with dual raid controller modules (dual port) and have been using it for years with great success. I got a warning that the battery needed to be replaced in module 1 (age). So I bought two on eBay just in case the other module needs the same. I removed the module and replaced the battery. I'm connected to a Dell PowerConnect 6248 managed switch.

When I online'd module 1 the entire network, i.e. web sites etc. appeared extremely degraded and I'm not seeing steady/reliable network activity lights on the two data ports on the module. No amber lights anywhere on the unit or module. It appears something has gone bad or config lost on the iSCSI data ports. I have even tried going back to the original battery, same issue.

I can ping and connect to the management port and I can offline and online the module but it seems to be in some network contention either to failed ports/board or a config problem? I've tried everything I can think of to even rerunning the discovery software to try to connect and reconfigure the module but it won't discover the md3000i at all when module 1 is online. If I offline module 1 it will but then I can't configure the iSCSI ports on module 1 if it's offline. When I try to even access the iSCSI configuration from the management utility I get "Unable to obtain current iSCSI network settings for RAID controller module 1 port 1 (then after ok I get the same for port 0).

I reviewed the command line interface manual and even tried resetting the config on module 1, no change. I'm out of support and I even tried calling in to get configuration help but they won't unless I pay $600 which I don't want to do.

Any help would be appreciated. The unit is running fine on only module 0 but I obviously don't have the redundancy.

Thank you.

1
  • I found a replacement module (bought two) on eBay - swapped it and problem solved. Glad even the configuration automatically transferred to the replacement module. While I know the md3000i is old (bought this around 2009) I have to say it is still a fantastic piece of hardware for a SAN. – Neal Nov 16 '16 at 19:05
2

Neal,

You may be out of luck with this one if you're not able to pay for support. If this is a controller firmware / config problem, there's little chance you'd be able to get this resolved without extensive aid from back-line support at Dell... and if it turns out to be a problem with the hardware in the controller, you may not be able to get a replacement part from Dell at all given its age (I believe those systems are completely end-of-life now).

If the controller is actually booting, and it is not stuck in a "boot loop", I would expect this isn't a hardware problem.

3
  • I would add to your answer that if the OP reactive its hardware maintenance (if he can), the fee is backward calculated, often the price of a new unit is to think before reactivating a maintenance. – yagmoth555 Nov 11 '16 at 16:26
  • That's a great point, something many don't know about. Down side here is that the MD3000i is no longer eligible for warranty extension / reinstatement due to it's age. – JimNim Nov 11 '16 at 16:28
  • Thanks all - I was able to find raid modules on ebay and will try a replacement. Hoping I can drop in a new/unknown module and it won't affect the raid config, of course all data is offloaded prior to trying this in about two weeks. It's interesting that the cost of a used md3000i is almost the price I paid for the two spare raid modules on ebay, we'll see what happens. SAN's are expensive! – Neal Nov 12 '16 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.