1

I've rolled out a Folder Redirection/Offline Files GPO as of Monday and it's (mostly) been smooth. I deployed it at our other 2 "remote" sites that are connected to us via MPLS first and not a single blip at either one. I setup Desktop, Documents and Favorites to be redirected. For obvious reasons, I left Downloads, Pictures, Music and Videos alone (un-redirected, so still just on the local drives).

However, yesterday our CEO texted me at 8pm because the desktop items on his Surface Pro 4 had a gray "X" over them. I remoted to him and manually setup a new RDS shortcut so he could remote in (all he needed to do at the time). I explained that the Offline File sync failed to finish and left the desktop items in this state, but that I'd have to fix it tomorrow once the Surface was back on the LAN. However, I have the Surface on the LAN now and it still will not sync and **the green "Sync Center" icon is missing from the System Tray. I tried this to make the SS icon show up and it worked for my profile, but NOT his.

I have set the 3 paths to file server to be "Always Offline" (aka "Administratively assigned offline files") but it does not seem to be working:
\FileServer\Users\%Username%\Network-Desktop
\FileServer\Users\%Username%\Network-Docs
\FileServer\Users\%Username%\Network-Favs

Another issue I have is our DC is SBS 2008 (not R2), so the option to have Offline Files sync on a schedule (like every 5 mins or so would be nice) is apparently not possible...? And this is somehow dependent on slow-link mode?? Moreover, I'm just confused if we should use "Slow Link Mode" or not. Literally only 2 or 3 laptops are ever off our domain, and that's not all that often. The other 50ish computers are desktops on a LAN that use wired ethernet, so those are the priority.

So my questions are:
- How can I FORCE Offline Files to Sync down to his Surface after he is logged in?
- How can I get the Sync Center icon in the System Tray?

  • Getting somewhere now. I looked under Sync Center > Manage Offline Files > View you offline files: Desktop, Documents and Favorites were there BUT "Always Available Offline" was not checked. For whatever reason the GPO didn't assign the folders. I manually set them to Offline and they are syncing now. I'll test offline once the Sync finishes.... – SamAndrew81 Nov 10 '16 at 19:46
1

Apparently the workstations were going to sleep and not properly reestablishing the network link after waking up. Completely disabling sleep is a workaround, or you can do this (via option 2 here http://www.syswow64.co.uk/2012/09/windows-7-offline-files-will-not-go.html )

  • Locate and click the following registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\NetCache
  • Click Edit, point to New, and then click DWORD Value.
  • Type SilentForcedAutoReconnect and then press ENTER to name the value.
  • Double-click SilentForcedAutoReconnect. In the Value data box, type 1, and then click OK. A reboot is necessary to make the change take effect.

Other troubleshooting steps that helped:
- Run > CMD: GPupdate /Force
- Formatting the Offline Files cache

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.