0

I have a red hat satellite 5.7 with subscribed servers to the rhn under a 3.4 rhev installation and I just created a VM with RHEL 6.6, subscribed it with satellite to the rhn, configured the channels in the satellite console, did the check using rhn_check but when trying a yum update I get an error that yum cannot get the repository metadata (repomd.xml) for channel: rhel-x86_64-server-6.
I have other servers that already existed before me and work well with yum. I tried disabling updates in /etc/yum.repos.d/rhel-source.repo as checking other posts like this one or checking date and cleaning metadata as per here but got no luck.
What am I missing?
My repo file looks like this:

[rhel-source]
name=Red Hat Enterprise Linux $releasever - $basearch - Source
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/enterprise/$releasever/en/os/SRPMS/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

[rhel-source-beta]
name=Red Hat Enterprise Linux $releasever Beta - $basearch - Source
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/beta/$releasever/en/os/SRPMS/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta,file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
0

your repo file only has rhel-source and rhel-source-beta defined

It needs an entry for rhel-x86_64-server-6 so it can find the repodata xml file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.