0

Previously I've already been able to connect to my server with openVPN. Now I've set up a new one with the same configuration, if I remember correctly, and on a client when trying to connect I get this:

ERROR: Cannot open TUN/TAP dev /dev/net/tun: No such device (errno=19)
Exiting due to fatal error

I run it as "sudo openvpn client.ovpn".

  • Have you compiled the tun module? modprobe tun;lsmod |grep tun – Ipor Sircer Nov 16 '16 at 6:40
0

This seems a permission issue. I was getting similar problem on my Docker instance, and I solved it using --privileged option while executing the docker run command

0

Enable TUN/TAP device driver support in kernel.

  1. Open kernel menuconfig.
  2. Enable Device Drivers -> Network device support -> Universal TUN/TAP device driver support
  3. Compile and load the kernel again.

It will work!

0

If the other tricks don't work (in other words, you've already installed the kernel modules, etc), make sure that the line

alias char-major-10-200 tunode_tunnel

is in /lib/modules/.../modules.alias.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.