I have an FTP website running on IIS 8.5 on Windows Server 2012. I can connect just fine if I disable SSL. However, if I enable SSL, the server keeps sending weird replies. Here's the log from FileZilla:

Status: Connecting to XXXXXXX:21...
Status: Connection established, waiting for welcome message...
Response:   220 Microsoft FTP Service
Command:    AUTH TLS
Response:   502 AUTH command ok. Expecting TLS Negotiation.
Command:    AUTH SSL
Error:  Could not connect to server

Note how it says "502 AUTH command ok". I'm no expert on FTP, but from what I've seen on the internet, the status code should be 234, not 502. IIRC 502 actually means "command not implemented", which is not what the rest of the comment says. What's going on here?


I got a bit creative with this problem. First, I tried connecting to my own server on my own laptop. This has worked for over a year now, so no wonder it worked. Then, I moved my laptop to my workplace and connected it to the network there. I tried connecting to my own server again, I got the same error as above. I disconnected my laptop from the company's network and immediately tried again, this time via my phone's LTE connection. Guess what? Connection successful. It has to be something in the company's network that's preventing the connection... A firewall? A misconfigured proxy? Is this even possible? Any ideas on how to find the culprit?


I also faced the exact same error while connecting to a corporate FTP server using user name and password. Working fine from office, but giving the above error while connecting from home. Although for me WinSCP worked without any issue from both home and office. This looks like a problem with FileZilla client as all other settings were good.

| improve this answer | |

I dodn't quite think before posting, let's try again, shall we:

Make sure you enable the site to allow SSL connections

Check this link: https://www.iis.net/configreference/system.applicationhost/sites/site/ftpserver/security/ssl


| improve this answer | |
  • I will try that as soon as I get to work, but here's an interesting fact: I have another server with ftps set up. I can connect to it from home, as I have been for over a year now. From work, I have the same issue as with the other one. I also tried different ftp clients (I usually use filezilla, but I also tried cute ftp) and got the same results. – Arshia001 Dec 4 '16 at 4:40
  • Yes, I just checked, I have all of those options configured correctly. Check my update above. – Arshia001 Dec 4 '16 at 8:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.