1

Start of master fails with error:

6109 start_master.go:103] could not init cloud provider "openstack": Post http://10.175.1.110:5000/v2.0/tokens: dial tcp 10.175.1.110:5000: i/o timeout

The IP address in the request is not correct,it is the keystone "internal" endpoint, it should be "public".

Why is "internal" endpoint coming to use with start_master.go, and how to enforce usage of "public" one?

When using HEAT template to create OpenShift, public endpoint was specified for --parameter os_auth_url

That public endpoint is not in any config file on the system (not in master config file, not in cloud-init conf files). It looks like the URL is somehow dynamically created, but from what?

1

The URL can be specified in /etc/origin/cloudprovider and right selection of endpoint works if keystone v3 api is used, e.g.

https://<URL>:5000/v3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.