1

We have an Exchange Server (2010) on site that sends our mail to the world using MX(DNS) records. When I look at the queue, several domains have 421 4.4.2 Connection dropped due to ConnectionReset. I've telnet into the SMTP port of the servers refusing connection and doing HELO or EHLO (domain) always returns Syntax error the first time it is submitted. The second time the receiving server replies to the command. Once I get the HELO or EHLO command to be received it takes all other commands as normal.

    220 smtp-gateway2.carleton.ca ESMTP Service ready
EHLO **********.ca
500 Syntax error, command unrecognized
EHLO **********.ca
250-Requested mail action okay, completed
250-8BITMIME
250-SIZE 20480000
250-ETRN
250-STARTTLS
250 OK

No backspaces or any other keystrokes besides what you see. I'm using our domain name that would be sending the email in the sample above.

Could this be the reason I am seeing the 4.4.2 error in our send queue? If so what would be causing this issue?

To telnet I'm using putty from our Exchange Server.

Extra information: Web traffic for our company uses a different public IP than our Exchange server uses for mail/smtp. All information from Exchange that uses port 25 is forcefully being re-written to the correct public IP by the Firewall. There was an issue with mail having the incorrect public IP and being rejected because there is no rDNS for the web traffic IP.

  • I tried it a couple of times against that server and I could not reproduce that issue. I never got a syntax error and it responded properly the first EHLO. But, I was connected to that actual server, and you are not. Your connection seems to have been intercepted and diverted somewhere else. – Michael Hampton Nov 16 '16 at 20:53
  • Not sure what you mean by my connection was intercepted. – J.Houston Nov 16 '16 at 20:55
  • I mean I'm talking to smtp-gateway2.carleton.ca and it gives me completely different banners and responses. I think you're actually talking to some other server. – Michael Hampton Nov 16 '16 at 20:57
  • When I run a telnet session from my computer (which then uses the other public IP I get the following): 220 smtp-gateway2.carleton.ca ESMTP Sendmail 8.15.2/8.15.2; Wed, 16 Nov 2016 15:56:26 -0500 EHLO **********.ca 500 5.5.1 Command unrecognized: {{}EHLO **********.ca" EHLO **********.ca 250-smtp-gateway2.carleton.ca Hello [XXX.XXX.XX.42], pleased to meet you 250-ENHANCEDSTATUSCODES 250-PIPELINING 250-EXPN 250-VERB 250-8BITMIME 250-SIZE 36700160 250-ETRN 250-STARTTLS 250-DELIVERBY 250 HELP – J.Houston Nov 16 '16 at 20:59
  • OK, that's the correct server. So now we can be sure that the problem is on your local computer or network. You can see that some additional characters were sent before your first EHLO. – Michael Hampton Nov 16 '16 at 21:08
2

I think the problem is the active telnet mode that is standard in puTTY I had the same problem with puTTY then I changed the configuration under telnet from active to passive and it worked.

1

In your PuTTY Configuration for the connection to your Exchange Server, go to Category > Connection > Telnet, then change the Telnet negotiation mode from Active to Passive.

PuTTY Passive Negotiation

ref: PuTTY Documentation Help

4.16.2 Passive and active Telnet negotiation modes

In a Telnet connection, there are two types of data passed between the client and the server: actual text, and negotiations about which Telnet extra features to use.

PuTTY can use two different strategies for negotiation:

In active mode, PuTTY starts to send negotiations as soon as the connection is opened. In passive mode, PuTTY will wait to negotiate until it sees a negotiation from the server. The obvious disadvantage of passive mode is that if the server is also operating in a passive mode, then negotiation will never begin at all. For this reason PuTTY defaults to active mode.

However, sometimes passive mode is required in order to successfully get through certain types of firewall and Telnet proxy server. If you have confusing trouble with a firewall, you could try enabling passive mode to see if it helps.

  • This answer was already given by someone else. Be aware that when you are just adding details, you are also allowed to edit existing answers. – Michael Hampton Aug 16 '19 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.