0

I am currently connected remotely to my ESXi 6.0.0 server. I have a virtual machine on it that I have no problem using RDP to get to. However, when I run it via VMWare Workstation 12.5.2 build-4638234 - it only shows me the upper left portion of the screen.

Here are the 2 images that show exactly what is happening:

  • VMWare Workstation

    VMWare Workstation - Full Screen Image

  • RDP

    RDP - Full Screen Image

Now - the reason I NEED to run inside VMWare Workstation is because I am using a VPN inside of the image to connect to a customer who uses Cisco VPN. If I connect via RDP, it will shut off my RDP session. With Workstation - I don't have that issue.

  • Have you tried adjusting/changing any of the Display options in Preferences? – joeqwerty Nov 17 '16 at 2:03
  • Display options in windows? I don't see a lot of options for the video card in the virtual image settings, but maybe I am missing something? – Andrew Nov 17 '16 at 2:08
  • In VMware Workstation, go to the Edit menu, select Preferences, select Display, try changing some of the options. – joeqwerty Nov 17 '16 at 2:14
  • yes, I tried multiple settings. Couldn't find any that worked. – Andrew Nov 17 '16 at 2:18
  • Are you running workstation under Windows or Linux? On a side note - what you said about cisco VPN is correct, however you can replace Cisco VPN client with the vpnc or Shrewsoft VPN. Both will let you run your tunnel in a split tunnel mode, so you will not loose your rdp connection. – Dmitry Zayats Nov 17 '16 at 5:25
0

My hints:

  • Debug from the VMware vSphere Client, what I recommend you to try (it's free), as it is the natural and proper way to connect to your ESXi, and where you can open also the VMs console. Therefore, from there, you can see if the problem could be in the VM.
  • Install/update/remove and re-install your VMWare tools.

    • I think the better way to install them is from your vSphere Client, as it is connected to your ESXi, and it will mount the tools installer in the VM optical drive. As Workstation would try to mount its tools image to its managed VM, but the VM is on ESXi, I would say that this probably will fail (although I never tested it). Also, in this way, the proper tools for your ESXi version will be installed.
    • You can do it as shown in the screenshot below (taken from https://www.dedoimedo.com/computers/vmware-tools.html).

      enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.