1

I need to install subversion client with version something like 1.8. But I need it for ubuntu 16.04. In current repos version is obviously higher.

I tried to to find some sources or repos with needed version but I can't found abything useful except for few someonse private repos. Where can I find and install svn 1.8 client for ubuntu?

0

Get the source package from a previous version (apt-get source subversion=<exact version number>), install required libraries ( apt-get build-dep subversion) then build yourself with dpkg-buildpackage. You'll get a subversion-xx.deb, so dpkg -i subversion*deb.

  • ubuntu says that I should place sorces URI into sources.list. Tried to add deb http://ppa.launchpad.net/svn/ppa/ubuntu precise main deb-src http://ppa.launchpad.net/svn/ppa/ubuntu precise main but there is no change. – user1858864 Nov 18 '16 at 15:59
  • deb-src http://us.archive.ubuntu.com/ubuntu/ trusty main – Ipor Sircer Nov 18 '16 at 16:21

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.