0

I have the following my /etc/yum.repo.d directory:

[fixnetix-base]
name=Fixnetix Base
baseurl=http://10.20.82.149/os/rhel/x86_64/6.8
gpgcheck=0
enabled=1

[fixnetix-security]
name=Fixnetix Security
baseurl=http://10.20.82.149/repos/security/FXNX/6/latest
gpgcheck=0
enabled=1

[fixnetix-infra]
name=Fixnetix Infrastructure
mirrorlist=file:///etc/yum.repos.d/mirrorlist
gpgcheck=0
enabled=1

When I run yum repolist, no repository information is shown:

# yum repolist
repolist: 0

This is the effectively the same behavior as if there was no files in the directory.

This is fresh redhat 6 build with selinux enabled.

  • post /etc/yum.conf – kubanczyk Nov 19 '16 at 17:25
  • [main] cachedir=/var/cache/yum/$basearch/$releasever keepcache=0 debuglevel=2 logfile=/var/log/yum.log exactarch=1 obsoletes=1 gpgcheck=1 plugins=0 installonly_limit=3 – djc72uk Nov 19 '16 at 17:27
  • What is the file named ? – Iain Nov 19 '16 at 17:31
  • It has a .repo suffix – djc72uk Nov 19 '16 at 17:32
  • You should put the file in /etc/yum.repos.d, not /etc/yum.repo.d. You also need an active RHEL subscription. – Michael Hampton Nov 19 '16 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.