0

I just opened an Azure Automation account with a free subscription, in an attempt to experiment with DSC. I've been unable to register an on-premises node with the pull server, any help would be appreciated.

Set-DscLocalConfigurationManager -path C:\Users\eric\DSC\DscMetaConfigs -Verbose

the error I get is:

PS C:\WINDOWS\system32> Set-DscLocalConfigurationManager -path C:\Users\eric\DSC\DscMetaConfigs -Verbose VERBOSE: Performing the operation "Start-DscConfiguration: SendMetaConfigurationApply" on target "MSFT_DSCLocalConfigurationManager". VERBOSE: Perform operation 'Invoke CimMethod' with following parameters, ''methodName' = SendMetaConfigurationApply,'className' = MSFT_DSCLocalConfigurationManager,'namespaceName' = root/Microsoft/Windows/DesiredStateConfiguration'. The client cannot connect to the destination specified in the request. Verify that the service on the destination is running and is accepting requests. Consult the logs and documentation for the WS-Management service running on the destination, most commonly IIS or WinRM. If the destination is the WinRM service, run the following command on the destination to analyze and configure the WinRM service: "winrm quickconfig". + CategoryInfo : ConnectionError: (root/Microsoft/...gurationManager:String) [], CimException + FullyQualifiedErrorId : HRESULT 0x80338012 + PSComputerName : EricSamsungLaptop VERBOSE: Operation 'Invoke CimMethod' complete. VERBOSE: Set-DscLocalConfigurationManager finished in 10.097 seconds.

The node I'm attempting to register is a fully up-to-date Windows 10 machine. This node's network interface is set to "private", and I even tried temporarily disabling the firewall, but get the same result.

I've generated the .meta.mof with instructions from here: automation dsc onboarding, and also tried using the Get-AzureRmAutomationDscOnboardingMetaconfig cmdlet, but get the same result.

When using a web browser on the node to connect to the registration URL, I get an HTTP 503 error, so the node has connectivity to Azure.

1

I had to enable Power Shell Remoting (PS Remoting) to get the Windows 10 node added to Azure Automation. I enabled PS Remoting by running the following cmdlet from an elevated PowerShell session: Enable-PSRemoting.

Once enabled, the Set-DscLocalConfigurationManager cmdlet worked, and the node was added to my instance of Azure Automation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.