0

I'm unable to connect remotely to one of a number of servers on the network running 2012 R2 using the Windows RDC client.

Here is the error:

enter image description here

So far I've done the following:

  • Ping the server in question. Connectivity = fine.
  • Checked Remote Desktop is enabled (system properties > remote > allow remote connections to this computer)
  • Windows firewall is currently turned OFF for all profiles (domain, private, public)
  • telnet from another machine on the network to the server on port 3389: I just get a blank cursor, no connection
  • run netstat -o -a to check the server is listening on port 3389. It is, see below:

TCP 0.0.0.0:3389 servername:0 LISTENING 3236

  • I have also run qwinsta to check the RDC service is listening, see pic below:

enter image description here

  • I have rebooted the server, checked firewall on the client (and tested from multiple clients)
  • Nothing in event logs
  • I have changed the listening port (regedit > hklm\System\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp port) and done all of the above, same happens. netstat shows the node is listening on 3390 but can't connect by RDC client or telnet on that new port.

I followed this unusually thorough article on support.microsoft.com (despite it seems to refer to Server 2003) to troubleshoot further.

I'm concluding that I should somehow find a way to blat the RDC service and rebuild it. Is that possible?

  • The registry key should be named "PortNumber" not "port". And it should be set to 0x00000d3d (3389). When I inherited my network, the previous owners had changed all the port numbers because they didn't want anyone using remote desktop. Took me a while to figure it out. – HighTechGeek Nov 21 '16 at 20:23
  • I'm always a fan of changing the default port numbers, depending on how open the server may be to the outside world. Yes, I meant PortNumber - that key is set correctly. – hazymat Nov 21 '16 at 21:38
0

Had the same problem, here is my solution:

It actually happens to be a problem with the security layer negotiation between the RDP-Host and RDP-Client. Long story short, I had to manipulate a RDP-file on text level and had to change the following value:

negotiate security layer:i:0

Give it a try, maybe it helps you aswell

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.