3

I'm attempting to use VMware Standalone Converter version 6.11 (current version, installed very recently) to create a backup of an existing VMed Windows machine on a remote VMware hypervisor. However as soon as I give VMware Converter the source machine IP and login, it throws this error:

A general system error occurred: Not supported version: Unsupported version URI "urn:converter/7.0" while parsing SOAP body at line 6, column 0 while parsing SOAP envelope at line 2, column 0 while parsing HTTP request before method was determined at line 1, column 0.

Googling has left me none the wiser about what could be causing this, it appears to be a version mismatch of some kind but as I'm running an up to date version of Converter I'm not sure what is objecting to what?

Not sure if relevant, but if I attempt to connect to the hypervisor running the VM in question from the same Windows 10 laptop the Vsphere client installer it wants to download throws an error about "This can only be installed on Win XP SP2 or above" (it's V5). I'm wondering if there are support files that are needed from Vsphere before Converter will connect? And if so is there any way to persuade it that yes, Windows 10 is a version above XP SP2? Just a guess though.

Edit: I tried installing Vsphere from the hypervisor, and Converter, on a Windows 2003 machine on the same network. Vsphere accepted that as being "XP SP2 or above" and installed correctly and connects to the hypervisor quite happily. However Converter throws exactly the same error when given the login credentials of the VM I want to copy.

  • 1
    Which hypervisor exactly (esxi? workstation? which version?) is it you connect to when you get error? – Gerald Schneider Nov 22 '16 at 7:29
  • 1
    @GeraldSchneider The hypervisor the VM is currently on is ESXi 5.0.0. The error happens just after I give Converter the VM's username and password, when converter tries to connect to the VM. – Pyromancer Nov 22 '16 at 10:46
  • 1
    What Source Type do you have selected when you enter the details? Powered on -> Remote Windows Machine or Powered off -> VMware Infrastructure virtual machine`? And are the credentials for logging in directly to the VM, or are they for logging into the hypervisor? – Gerald Schneider Nov 22 '16 at 11:03
  • 1
    @GeraldSchneider: Powered On Remote Windows Machine, and the credentials are its IP, admin login username and password. I'm attempting to do a V2V clone in the same way I'd usually to a P2V clone when virtualising an existing physical machine. – Pyromancer Nov 22 '16 at 12:19
  • 1
    Is it possible that an older version of the converter or its agent is installed inside the VM? If yes, try to remove it. Alternatively you can install the Converter inside the VM you want to copy and then convert the "local machine". – Gerald Schneider Nov 22 '16 at 12:45
1

Is it possible that an older version of the converter or its agent is installed inside the VM? If yes, uninstall it. The VMware Converter installs its own agent automatically if you connect to the machine with administrator credentials.

4

In order to backup virtual machines, you should use something like free VEEAM Backup & Replication https://www.veeam.com/virtual-machine-backup-solution-free.html.

But if you prefer converter approach I would strongly recommend you using a 3rd party V2V converter by StarWind https://www.starwindsoftware.com/converter instead of VMwares. It's free and helped me a lot of times working with all the most commonly used VM formats: VMDK, VHD/VHDX, StarWind native IMG, QCOW. It works both ways, converting from and to any selected format, thus having better functionality than similar converters.

  • 2
    If I try the StarWind converter it connects to the source hypervisor OK and I can find the relevant machine and file but it complains that the file is in use. I'm guessing this means I would need to shut down the VM to do the copy, which I'm trying to avoid having to do, as it's running live services. – Pyromancer Nov 22 '16 at 11:05
  • 4
    Well, it's another thing then. In order to be able to copy a running virtual machine you need to create a snapshot of the VM (so it starts writing in a different file and releases the initial VMDK), do all the needed operations and then consolidate the snapshot back. Or clone it using vCenter while running and then convert the cloned one deleting it after you have finished. – Net Runner Nov 22 '16 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.