First off I am not a system/server admin but would like to know why the below happens.

I have a windows 2012 server lets call it 'server01.corp.com'. and there is another windows 2012 server lets call it 'server02.corp.com'.

When I try to connect 'server01.corp.com' through Remote desktop connection it gives me a login box and then after successful input it shows a Warning box saying 'Identity of remote computer cannot be verified.Do you want to connect anyway?' and their it also says "Name of certificate from remote computer as 'server02.corp.com'" (weird).

So, I click on 'Yes' meaning connect despite these certificate error.

Now comes the next weird part, Instead of connecting to 'server01.corp.com' (which was my intention) it connects to 'server02.corp.com'!!

Although title bar of remote desktop connection says i am connected to 'server01.corp.com' it login me into 'server02.corp.com'!

How is that possible?

Edit: we had to use 'server01.corp.com /admin' in remote desktop connection, it takes us to correct server!

Thank You


You have two servers - server01 and server02 - which are part of a RDS Farm. One of them (or a totally separate server) is a broker. When you connect to either server01 or server02, the server you are connecting to first has you log on, then consults the broker database to find if you already have a session on one of the two servers, if so, it sends you to that server. If not, it sends you to the "least busy" server (If I remember right, it's by # of users).

That's why you get this. The bar at the top of the RDP window shows the name you use in initiating the connection.

If you had a DNS entry called "rdp" for example, and that was pointing to either one of your server, or a round robin DNS entry with both, or point it to your broker, then you would see "rdp" in the bar, regardless of whether you have a session on server01 or server02.

Using mstsc /v server01 /admin logs you on with a Admin Console, and does not consult the broker database. Only administrators of the server can connect using the /admin option.

  • thanks for the answer ETL :) what is the purpose of this approach?. I mean server01 & server 02 are two different servers. Can you think of any reason why this is done? I feel it adds complexity (complexity itself adds confusion) – wenn32 Dec 12 '16 at 12:45
  • This is done when you want to balance the load between servers - for example, you provide a RDP service to users, to scale, you add multiple servers. If each servers are for different purpose, then you don't want to enable load balancing with a broker, but if they are the same purpose, it's the best. – ETL Dec 19 '16 at 2:31

Sounds a bit like a DNS issue. Are the DNS entries for the servers Static, or Dynamic ? Do you have an alias in place, re-directing the first server to the second ?

  • we had to use 'server01.corp.com /admin' in remote desktop connection, it takes us to correct server – wenn32 Nov 23 '16 at 12:55
  • do you think it could be problem with DNS? – wenn32 Nov 23 '16 at 12:56
  • It's always DNS. – mfinni Nov 23 '16 at 14:45
  • @mfinni - really? no it's definitely not "always DNS" that's really not true... – ETL Dec 10 '16 at 2:14
  • @wenn32 see my answer, it's not a DNS issue. – ETL Dec 10 '16 at 2:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.