5

So I've spent the last few hours trying to resolve this and have had no luck.

I have a Hyper-V 2016 Server running on AMD hardware. It has an ASUS TPM (though I've tried a Gigabyte TPM as well). However, it doesn't recognize it as a TPM.

Before I moved to Hyper-V server, I had the same issue on a GUI install of Windows, however I was able to resolve by manaully choosing the generic MS TPM driver, and then it worked.

Hyper-V server has no GUI, so that option isn't available.

Here's what I've tried:

Manually installing TPM.inf. That fails cause hardware ID doesn't match.

Pnputil seems more focused on 3rd party drivers

Devcon fails when pointing inf to hardware util.

Installing the official tpm drivers from Vendor while I was using a GUI windows didn't work, as Bitlocker didn't recognize it as a valid TPM, so I've not tried that on Hyper-V.

Any ideas?

4
  • What are you actually trying to accomplish ?
    – Overmind
    Commented Dec 28, 2017 at 8:10
  • Have you tried to apply Generic MS TPM driver using Microsoft Administrative tools? Commented Jan 15, 2018 at 18:12
  • Windows doesn't recognize the hardware correctly, so it doesn't install drivers. On GUI Windows, I can force the generic drive to install. However, on HyperV which is Server Core, I cant find a tool or command to install the generic driver since it doesn't match the hardware IDs
    – Will M
    Commented Jan 15, 2018 at 19:22
  • Try pointing Computer Management from another computer to your Hyper V server and then use device manager from within Computer Management as you usually would. Should let you at least try some generic drivers like you are thinking you would in GUI Commented Sep 29, 2018 at 21:59

1 Answer 1

0

try to install Driver hyper V server in automatic mode, do not initialize 3rd party drivers, do proper configuration of each module and try it again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .