1

If I assign any drive to E:, it doesn't show in Windows Explorer. I can navigate to it explicitly by typing E:\, but under "This PC" it never shows.

Disk Management:

Disk 1           Data (E:)
Basic            1863.01 GB NTFS
1863.02 GB       Healthy (Primary Partition)
Online

DISKPART, list volume:

Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
----------  ---  -----------  -----  ----------  -------  ---------  --------
Volume 5     E   Data         NTFS   Partition   1863 GB  Healthy

MOUNTVOL:

\\?\Volume{15521316-0000-0000-0000-100000000000}\
    E:\

Registry, HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

\DosDevices\E:   REG_BINARY   16 13 52 15 00 00 10 00 00 00 00 00

In drive properties -> Security, Authenticated Users have Modify and all lower permissions. Administrators have Full control.

If I assign this drive to F: either using Disk Management or Diskpart, it immediately shows up in Explorer. The drive is visible to some aspects of Windows. For example, in System Properties -> System Protection, Protection Settings, it knows about (E:) Data (Protection is Off).

I tried deleting all the REG_BINARY values at the above registry key, and immediately restarted. This did nothing.

Notice that in DISKPART, it does not say Boot, System, or Hidden in the Info column.

If I assign this drive a different drive letter, then plug in any other mass storage device which takes the free E:, it does the exact same thing: I can navigate to it manually by typing E:\ in the address bar of Windows Explorer. I can view it from a command prompt by typing dir E:. But it does not show under "This PC".

This is a new computer. I used Laplink PCmover to transfer all my files, settings, and software. The old computer didn't have an E drive. The new computer showed the E drive okay before running PCmover. Laplink technical support has been unhelpful in attempting to resolve this problem.

I wonder if there could be some kind of MiniFilter driver running that is somehow intercepting the Windows drive letter enumeration and preventing E from showing?

I have uninstalled Laplink PCmover and restarted, but this did not resolve the problem.

I have F: and G: drives showing just fine in "This PC", and can switch them around--just whatever is E: doesn't show.

How do I get this or any device, when assigned to E:, to show in Explorer?

1

Very similar to the policy "Hide these specified drives in My Computer".

With a standard template it can hide the drives up to D letter, but here described as a hide any drive. Try check "NoDrives" registry value in HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Note that after changing this value you will probably have to restart for changes to take effect immediately.

1
  • Indeed, I found the value 18 00 00 in NoDrives which maps to hiding drives D and E. I changed it to 08 00 00 and drive E appeared`! Thank you very much. I was so certain there was a registry setting of some kind that was interfering with displaying the drive letter. (P.S. Dealing with local policy on Windows 10 Home is a giant pain in the neck!) – ErikE Nov 25 '16 at 7:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.