13

When I run lsb_release on Debian 8, following error is appeared:

No LSB modules are available.

Is there any missing file causes this problem?

24

As the error message says lsb_release command is installed but lsb module isn't. Use this command to solve the problem:

apt-get install lsb-core

I suggest to use lsb_release -a instead of lsb_release. It shows more useful output.

4
  • 1
    This doesn't work on my debian stretch. Any other ideas?
    – QILIN LU
    Jul 2 '18 at 15:45
  • 1
    What is the problem? you can't install lsb-core or running ip causes errors?
    – SuB
    Jul 5 '18 at 9:28
  • 1
    @SuB On Stretch lsb-compat is installed instead as replacement for lsb-core and after this is installed it changes nothing. lsb_release -a still outputs No LSB modules are available. (together with the excepted useful output, so it is not really a problem but still irritating).
    – kayahr
    Jul 6 '18 at 12:20
  • On Ubuntu 18 lsb_release -cs worked, then it stopped oddly. I installed lsb-core and it works like a butterfly, ty.
    – JREAM
    Jul 29 '18 at 21:37
6

I just moved to Debian 11, Bullseye and, in order to check the release, you have to type

lsb_release -cs

lsb-core in Bullseye does not exist.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.