0

My server is set to ssl only and the only site available is this:

 <IfModule mod_ssl.c>
 <VirtualHost _default_:443>
 ErrorDocument 400 /index.html
 ErrorDocument 401 /index.html
 ErrorDocument 402 /index.html
 ErrorDocument 403 /index.html
 ErrorDocument 404 /index.html
 ErrorDocument 405 /index.html
 ErrorDocument 406 /index.html
 ErrorDocument 407 /index.html
 ErrorDocument 408 /index.html
 ErrorDocument 409 /index.html
 ErrorDocument 410 /index.html
 ErrorDocument 411 /index.html
 ErrorDocument 412 /index.html
 ErrorDocument 413 /index.html
 ErrorDocument 414 /index.html
 ErrorDocument 415 /index.html
 ErrorDocument 416 /index.html
 ErrorDocument 417 /index.html
 ErrorDocument 500 /index.html
 ErrorDocument 501 /index.html
 ErrorDocument 502 /index.html
 ErrorDocument 503 /index.html
 ErrorDocument 504 /index.html
 ErrorDocument 505 /index.html
 <IfModule security2_module>
 SecRuleEngine Off
 </IfModule>
 ServerAdmin [email protected]
 ServerName update.my-site.com
 ServerAlias www.update.my-site.com
 DocumentRoot /var/www/update.my-site.com
 <Directory />
  Options FollowSymLinks
  AllowOverride None
 </Directory>
 <Directory /var/www/update.my-site.com>
  Options Indexes FollowSymLinks MultiViews
  AllowOverride None
  Order allow,deny
  allow from all
 </Directory>
 ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
 <Directory "/usr/lib/cgi-bin">
  AllowOverride None
  Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
  Order allow,deny
  Allow from all
 </Directory>
 ErrorLog ${APACHE_LOG_DIR}/error.log
 LogLevel warn
 CustomLog ${APACHE_LOG_DIR}/ssl_access.log combined
 Alias /doc/ "/usr/share/doc/"
 <Directory "/usr/share/doc/">
  Options Indexes MultiViews FollowSymLinks
  AllowOverride None
  Order deny,allow
  Deny from all
  Allow from 127.0.0.0/255.0.0.0 ::1/128
 </Directory>
 SSLProtocol all -SSLv2 -SSLv3
 SSLHonorCipherOrder On
 SSLCipherSuite EECDH+ECDSA+AESGCM:EECDH+aRSA+AESGCM:EECDH+ECDSA+SHA384:EECDH+ECDSA+SHA256:EECDH+aRSA+SHA384:EECDH+aRSA+SHA256:EECDH:EDH+aRSA:!aNULL:!eNULL:!LOW:!3DES:!MD5:!EXP:!PSK:!SRP:!DSS:!RC4
 SSLEngine on
 SSLCertificateFile   /etc/apache2/ssl/2_my-site.com.crt
 SSLCertificateKeyFile  /etc/apache2/ssl/my-site.key
 SSLCertificateChainFile    /etc/apache2/ssl/1_root_bundle.crt
 <FilesMatch "\.(cgi|shtml|phtml|php)$">
  SSLOptions +StdEnvVars
 </FilesMatch>
 <Directory /usr/lib/cgi-bin>
  SSLOptions +StdEnvVars
 </Directory>
 </VirtualHost>
 </IfModule>

I can't connect to the server at all via the web although the DNS points to the right ip, what's happening though is that if I type in the servers ip address to the browser then the browser then goes https://site-ip but still shows a 404.

/var/log/apache2/access.log does not record any visits by anyone but /var/log/apache2/other_vhosts_access.log does record my visit as so:

 server3.my-site.com:80 70.168.134.25 - - [27/Nov/2016:10:33:11 -0500] "POST /office/papi/file.php HTTP/1.1" 302 573 "-" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB7.5; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; MDDC; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.1; OfficeLiveConnector.1.5; OfficeLivePatch.1.3)"

but the ip it shows is not my own.

No errors in any log.

Any pointers on where to debug?

1 Answer 1

0

Try this:

<VirtualHost server_ip:443>

instead of

<VirtualHost _default_:443>

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .