1

NB: I'm an AWS noob.

I followed the instructions to set up SES receiving (no sending needed) for my domain to write incoming emails to an S3 bucket. The domain is managed through Route 53 & verified (as per https://docs.aws.amazon.com/ses/latest/DeveloperGuide/receiving-email-getting-started-verify.html), the MX & TXT records are set up (used endpoint inbound-smtp.us-east-1.amazonaws.com as per https://docs.aws.amazon.com/ses/latest/DeveloperGuide/regions.html), I set up a receipt rule (as per https://docs.aws.amazon.com/ses/latest/DeveloperGuide/receiving-email-getting-started-receipt-rule.html) for admin@ (plus several other email addresses like postmaster@, hostmaster@, administrator@, etc), let SES set up the bucket permissions & confirmed them on the bucket (as per https://docs.aws.amazon.com/ses/latest/DeveloperGuide/receiving-email-permissions.html). Not using encryption, spam/virus filtering or IP address filtering. Rule set is enabled. I got the original message from Amazon (AMAZON_SES_SETUP_NOTIFICATION) in my bucket.

Everything appears to be configured correctly, but I receive no emails in the S3 bucket. No errors, nothing in CloudWatch (not even a means to monitor SES), no bounces, nothing.

Any ideas?

  • What if you send yourself an email from, say, a gmail account? No bounce back to the gmail box? Not even after several hours? – Michael - sqlbot Nov 30 '16 at 4:28
  • Did that. No bounces, nothing. – Matthew Adams Nov 30 '16 at 14:30
  • Update: can successfully send via SMTP using SES. Added an SNS topic called "ses_rcpt" that I've confirmed is working properly (by adding an SMS subscription to my mobile phone and testing). When I send via SES's SMTP interface to one of the emails I've configured in my ruleset to receive via SES, CloudWatch shows the send, but no delivery, and nothing hits the SNS topic & nothing is in the S3 bucket. – Matthew Adams Nov 30 '16 at 16:41
  • Strangely & all of the sudden, email reception starting working. The floodgates opened on all of my test emails, and my phone is blowing up from the SNS topic's SMS subscription. Cause is a mystery, but working now. – Matthew Adams Nov 30 '16 at 17:23
1

I stumbled upon your question because I had the same issue of not receiving mails despite totally correct setup in SES.

However, in my case I didn't use Route 53 but registered the domain on another hosting service, including the DNS settings, especially the MX records. Looking in the DNS entries I've found that the priorities in the MX records were wrong, still pointing to my "old" mail server. The SES entry had lower priority which explained that no mails were sent to SES.

Solution was to change MX entry priorities, having a higher priority for the SES server.

Note, that this does not apply to your case since you used Route 53 for DNS setup, and should only be mentioned as another possible error source.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.