Server 2012 R2 ESXI 6

I am having an issue with resetting the local admin password on a windows server 2012 VM.

I first booted to a windows server 2012 cd, hit the repair option -> toubleshooting -> command prompt


The system cannot find the the drive specified

wmic logicaldisk get name




Neither of these are the drive where the OS lives.

So i booted to a windows 8 recovery disk

Couple other option when i select the repair windows option under that recovery console i get an error:

The drive where windows is installed is locked.

I have tried various way to unlock it but cannot get anywhere.

Things I have tried


list disk

there are no fixed disks to show.

bootrec /ScanOS

Total identified Windows installations: 0

Why is the local c: not showing up?

If i reboot the vm and not boot to CD the OS will load fine. Just can't log in.


I just tried to install the OS from the boot media, and could not find the local disk there either, defiantly a driver issue, I will try again tomorrow when i find the right driver and can slipstream it into the ISO


Your partition/disk got removed (within ESX) as your list disk within diskpart find nothing.

Check your hardware. A human error that removed the partition, or just unplugged it maybe if lucky. (or a storage array error at your esx level)

  • If he can get into the VM, but not the OS, it wouldn't be a storage issue unless the VMX and VMDK are on separate datastores on separate storage systems. It sounds like the VMDK was disconnected from the VM like you said. Dec 14 '16 at 14:35

Sorry to the user that attempted to answer they question but unfortunately you are both incorrect.

I was actually able to fix the issue and completely forgot about the question here.

I had to call VMware, turns out we were on a older version of vcenter and had to upgrade, had to pay the licensing cost and get the version that supported vAPPS, go through a very long migration process, get everything over to the new systems and decomm/reuse the clusters one by one to get the all over.

I couple hours of downtime later and not so happy CIO we were able to get everything setup and able to change the admin password through vcenter.

All this because the server owner forgot his password.

The reason we went through all this for one server is to be able to not have to go through this again in the future.


Click on the VM, click "Edit Settings". There should be a Hard Drive shown. If it's greyed out or there is no Hard Drive there, then that is why it can't be seen. If it's simply missing, you can add it back by selecting Add... and Hard Drive. Select Next and when it asks if this should be new or existing, select Existing. Browse your datastores for the folder your VM is in and attach the VMDK. Should be good to go after that.

If a snapshot was corrupted, this could also cause a problem with accessing the disk. If the HDD is there, but is showing mounted as /vmname-000001.vmdk or something like this, it is a snapshot and if it is missing from your VMX file, this might be the problem as well. If so, you'll likely need to restore from backup or call VMware.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.