0

I recently setup a new WSUS server (Server 2016 Core) and installed the console on my admin workstation. Everything was working fine but at some point something happened to the console and now it says "An unexpected error occurred". I'm given the options of unloading the WSUS span-in or copy the error message to the clipboard.

WSUS console

The process of unloading the snap-in never completes. Fortunately, the WSUS server itself still seems to work fine because I can use PowerShell to list needed updates and deny or approve them.

I've tried clearing the cached files from the console via File > Options... but that had no effect. I've also uninstalled the console and reinstalled it.

Any other ideas?

  • What happens if you disable your network before you load the WSUS console? Will it go ahead and open for you then? I am not sure but it might help narrow down if the problem is local or remote. If it does load then maybe there's a breakdown in the connection process. – JBaldridge Dec 2 '16 at 16:45
  • Good though but it didn't help. Even a console on another machine is broken still (I tried it yesterday). After disabling networking and clearing the console's cache, it still started up broken. I'm surprised by that. My guess is there's something wrong with the database on the server but how it broke the console so severely is a mystery. – Chris76786777 Dec 2 '16 at 18:00
  • WSUS is kind of a beast to find out why it's doing what it is doing. If you can connect to the WSUS database try looking at dbo.tbSingletonData -> ResetStateMachineNeeded and if that is True (1) then that will pretty much eat your WSUS server and cause connection issues locally on the console so I would imagine also remotely. If it's 0 then I'm not too sure. – JBaldridge Dec 2 '16 at 18:12
0

If you can switch to the GUI version (Yes, Is possible, you can go back to the core version after this change), Try this:

Stop IIS service.

Go to IIS console --> Application Pool --> Right Click on WsusPool -->Advance Settings.

Under Recycling --> Make sure to set the Private Memory Limit (KB) to 8000000 (you may need to assign more memory (RAM) to your server).

Restart IIS service.

Make sure the WsusPool is Started (IIS console --> Application Pool --> WsusPool Status).

Open WSUS console.

  • I was able to do this remotely with IIS Manager but it made no difference. I should point out that I set the Private Memory Limit to 0 (no limit) instead. – Chris76786777 Dec 1 '16 at 20:06

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.