2

I have a server running Windows Server 2012 R2 with IIS 8.5. I've configured it for remote management, and I am able to successfully connect to the IIS mangement service (on this server) from another computer, as long as I login with an "admin" account (an acct that's in the local Administrators group on the server).

I've tried to enable IIS Manager to allow non-admin accounts:

  1. I've enabled the remote Management Service: Mgmt Service
  2. I've added some non-admin users: Permissions

But, the non-admin users cannot connect to the IIS remote mgmt service: Unauthorized

As soon as I switch to an acct which is an admin on that server, it works: Authorized

How can I get IIS to allow non-admins to connect to the remote management service?

UPDATE: Based on the answer given below, non-server-admins need to choose the IIS Manager option "Connect to a Site", not "Connect to a Server". When you choose that option, you'll need to specify the Server name and the Site name:

site

3

Non-admins can connect to a web site. But only administrators can connect to the server. Reference Here.

|improve this answer|||||
  • Thanks. I was trying to "Connect to a Server", instead of "Connect to a Site". – jimtut Dec 12 '16 at 17:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.