0

I use Zabbix server 2.2, and after renaming a network interface in a Windows machine the discovery rules still sees the old interface name.

Even when running the discovery command in the cli like below, I get the old nic names:

zabbix_get -s servername -k "net.if.discovery"

Funny is that even with the wrong name, zabbix is able to get the stats from the interfaces so it is probably using another information to id the interfaces.

Any idea?

0

It sounds like the interface might not have been renamed actually.

  • is it the same system?
  • is it maybe some user-visible name, while system name that identifies the interface has remained unchanged?

Have you tried to restart the Zabbix agent as well?

2
  • Sorry for the delay in answering. Yes I tried to restart the agent. Like you said looks like it id the interface using another string instead of the name. – Multihomed Jan 12 '17 at 19:09
  • What was the old name? How did you rename the interface? Where do you check the names? – Richlv Jan 16 '17 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.