0

I'm trying to add a CentOS 6.8 client to Spacewalk 2.6 to I can push out updates. In order to add the client I need to first install some packages: rhn-client-tools rhn-check rhn-setup rhnsd m2crypto yum-rhn-plugin rhncfg-actions.

When I try to install them with yum I get the following errors:

Error: Package: rhnlib-2.6.3-1.el7.noarch (spacewalk-client)
Requires: python(abi) = 2.7

I read that CentOS 6 requires python 2.6.6 and upgrading it will break yum. I tried installing python 2.7 but if I run 'python' it still points to 2.6.6. I tried adding an alias in /.bashrc and pointed to the python2.7. I tried to install again but it says that 2.6.6 is installed and I need 2.7.

I feel like there has to be a workaround for this. If there's a way to install the packages on a way to add the client without needing the packages I would greatly appreciate the help/assistance.

Thanks

2

You're trying to install packages from the spacewalk-client repository for CentOS 7 on CentOS 6. This has no chance of working. Install the correct packages instead.

  • Thank you for the help, that was the issue. Only problem I'm running into now is 'python-hwdata' is a dependency for the packages listed above but I can't find it when I search with yum. – jrd1989 Dec 8 '16 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.