0

So I have a RocketRaid 2314 that I was using to just extend my SATA ports, basically it wasn't being used to RAID the drives but just as standard ports. In Windows or Linux the drives would appear individually.

Well now I am reducing the number of drives, and would like to use a couple for other purposes but I found that I'm unable to use the drives outside of this RAID controller!

I've run dd style wipes, tried something called wipefs -a, but none seem to work. Whenever the drive is attached to the motherboard directly through a SATA port the POST on boot will detect a drive but then fail saying 3rd master slave has an error. Press F1 to continue.

In the BIOS the drive is not reported as "no device" but instead is presented as a an empty string: [].

I'm able to hit F1 and continue booting, but the drive never appears in any OS (windows or linux).

Now here's the kicker. I attached a drive that was never part of the RAID controller to the same SATA cable that's attached to the motherboard. And it worked completely fine! Also if I connect the RAID drive back through the RAID controller, it'll appear fine in the OS (and not throw that POST error)!

It's like the drive itself is tagged by the RAID controller and can't be used without it. Like I said earlier, I've tried many many things to wipe the drive and get it to work as a standard SATA drive. Has anyone else ever seen something like this?

-- Specs:

  • MSI 870-G45 Motherboard
  • AMD Phenom II x6 Processor
  • Samsung HD204UI (RAID Drives)
  • RocketRaid 2314 RAID controller
0

I'd like to provide more info, but the best I can advise is that the firmware on your RAID drives is formatted to work more efficiently with the firmware on the RAID controller. I've had this happen with Dell Equallogic SANs before. Our Procurement department tried to be cheap and purchase a 4TB SATA drive from a 3rd party instead of Dell and when we received the drive, the SAN wouldn't recognize it. Found out the firmware on the controller has to be the firmware installed by Dell. It would work on a different server, but would give that post error.

It sounds like the HDD firmware isn't recognized by the motherboard. If your BIOS is up to date but it still doesn't see it, you might be out of options.

  • SANs and some hardware RAIDs require certified firmwares, but the OP problem is the reverse: the motherboard do not see his SATA drive. I don't think your scenario is the same as the OP is facing. – shodanshok Dec 9 '16 at 8:19
  • These drives are known for having a firmware issue originally, and I'm attempting to re-write the firmware on the drives: knowledge.seagate.com/articles/en_US/FAQ/223571en Right now I'm having simple issues of getting a FreeDOS live disc to boot properly (with the needed firmware .exe file) – Chris Dec 9 '16 at 21:24
0

I strongly suspect that the problem does not lie with the drive, but with the motherboard. Evidently, your RocketRaid is able to work with the drive, but the motherboard's integrated SATA controller/BIOS has problem identifying it.

Try updating your motherboard BIOS and/or install the drive in another PC to see if it works here.

  • If the issue is the motherboard, then why do you think the normal (has never been on the RAID controller) works fine with the same cable plugged into the same SATA port? I could try updating the motherboard, thanks for the idea. I'm also having a buddy try one of the drives on his machine. – Chris Dec 9 '16 at 21:23
  • I think it is a compatibility problem between you motherboard and your specific disk firmware, not a general SATA problem. – shodanshok Dec 9 '16 at 21:53
  • That seems rather specific and odd figuring I could have purchased the drives off the shelf and attempted to attach them to my machine (and shouldn't have a problem?). It's been a long time but I think I had them attached to the motherboard before I purchased the RAID controller. I did attempt to update the firmware of the drives, but nothing changed. The drives may not have updated since it's the same version... sigh – Chris Dec 12 '16 at 14:35
-1

Crear first 64MB of the old drive. You can do it by command:

dd if=/dev/zero of=/dev/olddiskname bs=64M count=1
  • Thanks, but I've tried this :( – Chris Dec 9 '16 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.