-1

I'm trying to deploy the azure template located here https://azure.microsoft.com/en-us/resources/templates/sharepoint-three-vm/

Everything appears to be working fine accept the first three variables shown in the screen shot. screenshot

Can someone help shed some light on the problem?

Cheers

1

Your error message says it all.

enter image description here

Replace the image size, or replace the region you're trying to run your PowerShell at.

Edit: instead of trying to guess your way into finding the right VM size and the appropriate location to host it, take a look at the Azure Products by Region page. All the VM sizes are there with their available locations.

  • Wow. I didn't see that. I will change that and try again. Will keep you posted. Cheer – Carltonp Dec 8 '16 at 22:29
  • Which region do you select? Maybe you could try to check if you have permission to create a Standard_DS1 size VM in the same region on Azure Portal. – Shui shengbao Dec 9 '16 at 7:53
  • Hi @Walter-MSFT, I selected ukwest as the region. I have tried many regions and I still get the same error. I also tried Standard_DS1 and got the same error – Carltonp Dec 9 '16 at 10:12
  • 1
    @Walter-MSFT, I changed the VM size to Standard_AS1 and I got the following error message \"Storage account type Premium_LRS is not supported for VM size Standard_A – Carltonp Dec 9 '16 at 11:03
  • Sorry, I meant to say I changed the VM size to A1, not AS1. – Carltonp Dec 9 '16 at 11:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.