I have set up a KMS server on a 2003 server with the lastest update to KMS for windows 7 and 2008 R2 support. I have registered the win 7 enterprise kms key on the kms server. When the clients try to connect they come up with the following error Error: 0xc004f038 The software Licensing service reported that the computer could not be activated. The count reported by your key management service (KMS) is insufficient.

I know this error means that the KMS server has not reached 25 activations yet. But I have 38 devices that were imaged from a syspreped windows 7 enterprise.

I have tried to follow this link http://support.microsoft.com/kb/929829 But I have built my image from a sysprepped image so the CMIDS should be fine. The commands that they say to use in this KB dont show the CMIDS either.

Any Ideas how I cant activate these Machines? Or is it a matter of playing the waiting game.



You say the CMIDs should be fine, but you haven't actually verified them. You need to find out whether all of the machines really do have unique CMIDs or not.

The KB article tells you to run slmgr.vbs -dli on the clients. And you say the output wasn't displaying the CMID. Did you actually run the command on the client workstations? Or did you accidentally run in on your KMS server instead? Running slmgr.vbs –dli on the KMS server won't show a "Client Machine ID" because it's not a client. So make sure you run the command on your clients and then compare the CMIDs to make sure they're not identical.

For instance, on my sample Win7 box, I get the following output from slmgr.vbs -dli:

Name: Windows(R) 7, Enterprise edition
Description: Windows Operating System - Windows(R) 7, VOLUME_KMSCLIENT channel
Partial Product Key: XXXX
License Status: Licensed
Volume activation expiration: 247500 minute(s) (171 day(s))

Key Management Service client information
    Client Machine ID (CMID): 12910304-af39-4fc9-80df-f8c61526d9f9
    Registered KMS machine name: mykms.mydomain.com:1688
    KMS machine extended PID: 55041-00168-305-100667-03-1033-6002.0000-2372009
    Activation interval: 120 minutes
    Renewal interval: 10080 minutes
    KMS host caching is enabled

So the CMID on that machine is 12910304-af39-4fc9-80df-f8c61526d9f9.

  • I ran that command on the windows 7 client and still did not get the CMIDS output. This is what I got --------------------------- Windows Script Host --------------------------- Name: Windows(R) 7, Enterprise edition Description: Windows Operating System - Windows(R) 7, VOLUME_KMSCLIENT channel Partial Product Key: HVTHH License Status: Initial grace period Time remaining: 40380 minute(s) (28 day(s)) Please use slmgr.vbs /ato to activate and update KMS client information in order to update values. --------------------------- OK --------------------------- – JohnyV Nov 6 '09 at 1:50
  • Is that after you tried to activate against your kms or before? – Ryan Bolger Nov 6 '09 at 17:16
  • after, I think I may have found the problem...I followed a guide for the unattend file and it used skip rearm. I read a microsoft KB and it has in there that you should not use skip rearm to generate new CMID's I am trying a new image and will sysprep that and see if it works. Running the slmgr -rearm seemed to increase the count on the KMS it is now at 7 instead of 3 prior to the testing. – JohnyV Nov 9 '09 at 0:38
  • Problem solved. I used the VAMT tool included with WAIK. ON the workstation devices I configured the firewall to allow WMI then ran slmgr -rearm. on all the devices. through the VAMT console I selected the devices to use configure for KMS activation. then once the count got to 25 they automatically started to register. I now have an image that does not have rearm in the unattend. And I just ran the slmgr -dlv command after it was activated and it does show the CMID. But it did not show it before. Thanks for you pointers. – JohnyV Nov 9 '09 at 6:12

You can also pull your KMS logs on the KMS host, comma delimited parse them, and sort by CMID. If you see a bunch of servers with the same CMID then you will know if your install/setup is going correctly.


Assuming your CMIDs really are all unique, check the system clock on the clients and the KMS server. If the clocks are not synchronized closely enough, that could also be your problem. I'm not exactly sure what the time difference threshold is though.

  • Time is in sync using a time server on the network. Thanks for the idea though – JohnyV Nov 6 '09 at 1:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.