-1

I'm in urgent need of help. My website is down and I don't know where to begin troubleshooting.

I have a GoDaddy domain and am running an AWS EC2 instance.

The Issue:

  • When I try to access the website from my chrome browser, it keeps loading, and keeps saying "Waiting for www.xyz.com...". In my Developer Tools window, I do not see any request being sent to the URL.

  • I am able to connect to my EC2 instance via terminal and see the server running live. No request is being received.

Where could the problem be? How do I check where the request is failing?

Any help would be appreciated.

++++++++++ BELOW IS THE TRACEROUTE Results ++++++++++++++

traceroute to www.xyz.co (xx.xx.xx.xx), 30 hops max, 60 byte packets

1               *   *   *


2   core22.hetzner.de   213.239.229.133 de  0.188 ms         
core21.hetzner.de   213.239.229.129 de  0.246 ms    0.251 ms


3   core1.hetzner.de    213.239.245.177 de  4.909 ms         
core4.hetzner.de    213.239.245.18  de  4.871 ms     
core1.hetzner.de    213.239.245.177 de  4.909 ms


4   juniper4.ffm.hetzner.de 213.239.245.10  de  4.948 ms    4.956 ms     
        in  


5   ae1-710.fra20.core-backbone.com 80.255.15.121   de  4.960 ms    4.974 ms    4.982 ms


6   ffm-b4-link.telia.net   213.248.81.209      4.985 ms    5.020 ms    5.026 ms


7   ffm-bb3-link.telia.net  62.115.120.3        5.455 ms         
ffm-bb3-link.telia.net  62.115.120.1        5.545 ms     
ffm-bb4-link.telia.net  62.115.120.9        5.459 ms


8   nyk-bb4-link.telia.net  62.115.139.15       99.212 ms        
ffm-b1-link.telia.net   62.115.116.162      5.777 ms     
nyk-bb1-link.telia.net  213.155.135.61      93.229 ms


9   chi-b21-link.telia.net  213.155.131.241     116.821 ms       
ffm-bb4-link.telia.net  62.115.116.159      104.857 ms   
chi-b21-link.telia.net  80.91.246.18        123.398 ms


10  hbg-bb1-link.telia.net  62.115.123.81       12.153 ms        
hbg-bb1-link.telia.net  62.115.123.77       12.160 ms    
sea-b1-link.telia.net   62.115.117.48       162.375 ms


11  amazon-ic-307566-sea-b1.c.telia.net 62.115.47.198       164.111 ms       
kbn-bb4-link.telia.net  62.115.119.250      24.006 ms    
amazon-ic-307566-sea-b1.c.telia.net 62.115.47.198       164.111 ms


12  nyk-bb1-link.telia.net  80.91.249.24        96.662 ms   *   *


13              *   *   *


14  sea-b1-link.telia.net   62.115.116.140      163.699 ms  164.885 ms  167.923 ms


15  amazon-ic-307562-sea-b1.c.telia.net 213.248.92.242      166.730 ms  *    
amazon-ic-302506-sea-b1.c.telia.net 213.248.84.190      164.407 ms


16              *   *   *


17              *   *   *


18              *   *   *

No reply for 3 hops. Assuming we reached firewall.

  • Did you checked security group settings? – Vikelidis Kostas Dec 9 '16 at 8:49
  • What is the URL to the website? Was this ever working? – varlogtim Dec 9 '16 at 8:53
  • Yea my security group settings seem to be fine. The site has been running properly, using the same settings. Suddenly this morning, I'm unable to reach it. – Utkarsh Sinha Dec 9 '16 at 8:54
  • What OS is running? What troubleshooting have you done other than noticed it is spinning? – varlogtim Dec 9 '16 at 9:01
  • @UtkarshSinha, if you are sure the server is ok, then you need to check the connectivity to the server. Is it publicly visible on port 80 (try a simple telnet for example)? Can you reach it over internet with hostname/ip on any other service (ssh for example)? Is the name resolution working correctly? Can you reach outside world from the server? – Diamant Dec 9 '16 at 9:09
0

Since the traceroute is resolving IP, I think it is not a DNS issue. To confirm check what @mzhaase suggested in comments. Also try

telnet www.xyz.com 80

telnet IP-Address 80 (assuming that your website runs in port 80).

Normally the issue related to "Waiting for www.xyz.com..." is due to the server limit in the webserver ie Maxclients in apache. It is the maximum amount of requests that can be served simultaneously, with any number going past the limit being queued and the user will get "Waiting for www.xyz.com..." kind of a message.

A rough googling gives me these link which might help you to tweak apache link1 and link2. It is better to contact your hosting provider to do this if you are not used with apache configuration.

This link will help you get more clarification about connections in apache.

NOTE that if this is the issue, you might be able to access the website sometimes and sometimes not.

0

UPDATE - Latest 12Dec2016

Hi all, I had posted an answer previously, which in hindsight seems like an incomplete resolution. My EC2 server actually has Apache2 and DjangoChannels installed on it. It also uses an external Redis Server (separate AWS EC2).

Incorrectness of Previous Resolution : Previously I had restarted the first EC2, which had restarted the Apache2 and the site started getting delivered through Apache instead of Django Channels. I didn't discover this until 2 days later when I noticed that a Django Channels dependent feature on the website wasn't working at all. So I stopped the Apache2 and restarted the DjangoChannels server (Daphne + workers); and I was back to square one.

Final Resolution - REBOOT THE REDIS AWS EC2 : Rebooting the Redis EC2 from the AWS Console, finally resolved the issue. The required configuration of Django Channels server and Redis Server started working. Also my Django Channels dependent feature came back up.


PREVIOUS ANSWER -

Thanks all for your help. I just resolved the issue.

REBOOT THE AWS EC2: All I did was reboot the AWS EC2 instance from the AWS Management Console. Although I'm not sure what was causing the problem, possibly RAM reached max-utilization.

More info: I had reached out to Amazon, they said there wasn't any outage at their end. So I thought of spinning up a new EC2. Before I did that, I luckily thought "I should probably reboot and check", which worked like a charm.

Do let me know if you have any other guesses why this might have worked, it might help understand the problem better for future instances.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.