2

I created an EC2 t2.micro instance and was able to SSH into the machine and install Redis. Redis is working since i can redis-cli into it and ping/pong it and write records from the command-line. I am allowing the Redis port in the Security Group for this machine however I am still unable to access Redis outside of the network. I even tried allowing all IPs access to 6379.

The security group looks like this: SSH - TCP - 22 - My IP Custom TCP - 6379 - 0.0.0.0/0

Is there some other firewall I need to allow this access to? I've tried connecting to the EC2 Redis instance from my home and from another network using a custom node application and Redis Desktop Manager.

1

The problem was the Digital Ocean guide I was following didn't mention protected mode or binding.

I needed to modify my redis.conf file and turn protected to no and bind 0.0.0.0. Search the conf file for protected and bind and you will find these values. You can also just comment out the bind line and that is effectively the same as setting it to 0.0.0.0.

Also, when you do this the conf document warns you that you are opening your server open to the internet so it's a good idea to have a firewall in place.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.