0

I'm not sure what I'm doing wrong. I basically used the latest arch linux live disk in a VM (Linux KVM),

  • booted the latest arch linux live disk in a VM (Linux KVM on Arch)
  • made a single partition
  • formatted that with btrfs -m dup
  • mounted the partition, ran pacstrap with base and base-devel
  • genfstab -U /mnt /mnt/etc/fstab
  • arch-chroot into the partition at /mnt
  • install grub through pacman, run grub-install /dev/vda and grub-mkconfig -o /etc/grub/grub.cfg
  • reboot
  • Grub throws a few error messages: "error: no such device: [some device ID].\n loading linux core repo kernel \n error no such partition \n loading initial ramdisk \n error you need to load the kernel first \n press any key to continue"

I can still boot the machine by going into the grub commandline, doing "linux (hd0,msdos1)/boot/vmlinuz...." and the same for initrd, and running "boot" to boot it, but that seems a little inconvenient. Yes I'm cutting short some things like hostname and what not, but it should boot as far as I know.

Does anyone know what I'm doing wrong?

Edit: I changed /etc/default/grub to not use UUIDs and ran grub-mkconfig again, here's the grub.cfg it generated: http://pastebin.ca/3746197 it still will not boot, though.

2 Answers 2

1

I found the problem. Not proud of my findings.

It's supposed to be grub-mkconfig -o /boot/grub/grub.cfg, not /etc/grub/grub.cfg. D'oh!

Leaving this here in case anyone else runs into it.

0

This is a common error with grub.

Try going into /etc/default/grub and turning off UUIDs, then running grub-mkconfig again.

6
  • I just tried this, but it doesn't change anything. in /etc/grub/grub.cfg I still see it using UUIDs... (I did run grub-mkconfig -o /etc ...)
    – Alex
    Commented Dec 11, 2016 at 2:59
  • I rebooted and ran it again, it seems to use UUIDs for some parts and /dev/vdaX format for others.. but it stil won't boot.
    – Alex
    Commented Dec 11, 2016 at 3:17
  • @Alex Hmm.. strange. What error is it giving you?
    – anna328p
    Commented Dec 11, 2016 at 3:18
  • still the same "error no such device [rootfs UUID]" stuff
    – Alex
    Commented Dec 11, 2016 at 3:24
  • @Alex Shouldn't be giving UUID errors... Try looking at your /etc/fstab and replacing the UUIDs there with /dev/vdwhatever
    – anna328p
    Commented Dec 11, 2016 at 3:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .