0

I recently inherited a Cisco 2901 router and have, literally, 0 experience managing this device.

I need help configuring a Site-to-Site VPN between my premises:

  1. IP: 5.5.5.1
  2. Subnet: 10.4.0.0/15 (255.254.0.0)
  3. VLAN: 200 (My guess is that it might not be possible to allow traffic only of a specific VLAN to this VPN but I thought i'd give it a shot).

and Google Cloud VPN:

  1. IP: 6.6.6.1
  2. Subnet: 192.168.1/20 (255.255.240.0)

Pre-shared key: much-secure-wow

For the life of me I can't get this to work and after spending enough time I thought to try my lack here.

  • The steps to configure Cloud VPN are documented on [this link(cloud.google.com/compute/docs/vpn/creating-vpns). You need to make sure you are using the same IKE version along with the same parameters on both sides of the tunnel i.e Cloud VPN and your Cisco router. You can check the logs for Cloud VPN and your Cisco router for useful debugging information. – Faizan Dec 15 '16 at 20:24
  • Were you ever able to solve this issue? If so please consider posting a self-answer so the community can benefit. – Faizan Feb 14 '17 at 22:10
1

Posting my comment as answer for other users looking at this thread.

You need to make sure you are using the same IKE version along with the same parameters on both sides of the tunnel i.e Cloud VPN and your Cisco router. You can check the logs for Cloud VPN and your Cisco router for useful debugging information. The steps to configure Cloud VPN are documented here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.